EM app-profile install location doesn't support pointers to extensions on different drives

RESOLVED DUPLICATE of bug 291807

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED DUPLICATE of bug 291807
13 years ago
9 years ago

People

(Reporter: Darin Fisher, Assigned: rstrong)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
EM app-profile install location doesn't support pointers to extensions on
different drives.

This bug is caused by the bug in the GetRelativeDescriptor implementation.  I
think that we should probably only use a relative file descriptor for
app-profile when the extension is in a subdirectory of the extensions/ folder. 
Otherwise, we should use an absolute descriptor.  Another approach would be to
fix nsLocalFile.

This isn't a critical bug since this use case is pretty infrequent and would
only be hit by extension developers, but it does seem like something worth
fixing if we have time before Firefox 1.5.

Comment 1

13 years ago
Are you sure about this? I could have sworn that I fixed this with the check at
http://lxr.mozilla.org/mozilla/source/toolkit/mozapps/extensions/src/nsExtensionManager.js.in#383
(only use relative descriptor if the profile dir "contains" the extension dir).
(Reporter)

Comment 2

13 years ago
Ah, I think DPA2 was being tested at the time.  |itemLocation| is definitely the
location of the directory, and not the location of the pointer file, right?  I
will test to confirm that this is fixed on the trunk...

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 291807 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.