Pressing enter on first screen of create a profile wizard automatically creates a new profile (doesn't go to the screen where you selecte name/location)

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: pablo, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050811 Firefox/1.0+

When you are creating a new profile, enter key and next(default) button act
differently


Reproducible: Always

Steps to Reproduce:
1.Open profile manager
2. try to create a new profile.
3. hit enter key

Actual Results:  
a new profile is created

Expected Results:  
next screen is shown

if you hit next with the mouse, works ok.
Doesn't happen on 1.0.6

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050812 Firefox/1.0+
ID:2005081210

For me, the default button that's focused on the first screen is "Cancel". So
hitting enter automatically cancels the creation of a new profile.

Comment 2

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050823
Firefox/1.0+ ID:2005082305

Reporter, can you reproduce with the latest branch build?

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8
(Reporter)

Comment 3

13 years ago
Yes, I've just updated to the latest hourly "Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.8b4) Gecko/20050826 Firefox/1.0+ ID:2005082602" and I can still
reproduce it.

Comment 4

13 years ago
Please retest this after the patch for bug 300227 lands. 
Severity: normal → minor
Status: UNCONFIRMED → NEW
Depends on: 300227
Ever confirmed: true
Summary: automatically created profile → Pressing enter on first screen of create a profile wizard automatically creates a new profile (doesn't go to the screen where you selecte name/location)
Version: unspecified → Trunk
(Reporter)

Comment 5

13 years ago
Seems to be ok on the trunk after 300227 landed. Nothing on branch yet.

Comment 6

13 years ago
Fixed by bug 300227.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.