Closed Bug 304459 Opened 19 years ago Closed 19 years ago

Object.prototype leaks from document to document after splitwindow changes.

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jst, Assigned: jst)

References

Details

(Keywords: fixed1.8, Whiteboard: [sg:fix][Fix in bug 303981])

As reported in bug 304423 by shutdown@flashmail.com, we now leak
Object.prototype from document to document. This was caused by the splitwindow
landing.
Status: NEW → ASSIGNED
Depends on: splitwindows
Whiteboard: [sg:fix]
From bug 304423:
> And something that might be related to the above:
> 1. load http://www.mozilla.org/
> 2. load javascript: Object.prototype.x="oops"; void 0;
> 3. load http://www.google.com/intl/en/
> 4. load javascript: alert(x);
> build 20050730 => "Error: x is not defined" in JS console
> build 20050811 => alerts "oops"

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050816 Firefox/1.0+
javascript: alert(x); // step 4
=> "Error: x is not defined" in JS console
javascript: alert(window.x);
=> alerts "oops"

Something has changed between 20050811 and 20050816.
Yeah, we changed where javascript: URLs are evaluated, they're now evaluated in
the inner window's scope which made this less apparent. The problem is still
there tho...
Blocks: splitwindows
No longer depends on: splitwindows
The fix for this is now in bug 303981 (only because the same code has to be
moved to fix both bugs...).
Whiteboard: [sg:fix] → [sg:fix][Fix in bug 303981]
Fixed by the fix in bug 303981.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.