Closed Bug 304469 Opened 15 years ago Closed 15 years ago

Add -new-tab option to auto-remote

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.8beta4

People

(Reporter: akkzilla, Assigned: Gavin)

Details

(Keywords: fixed1.8, regression)

Attachments

(1 file)

There's no longer a reliable way to open a url in a new tab (see bug 298960).
Bsmedberg said implementing a -new-tab commandline option, similar to the
existing -new-window option, wouldn't be hard at all, so I'm filing this to make
sure the request doesn't get lost.
Attached patch patchSplinter Review
Assignee: benjamin → gavin.sharp
Status: NEW → ASSIGNED
Attachment #192608 - Flags: first-review?(benjamin)
Thanks! Works nicely here. I can even pass multiple -new-window and -new-tab
clauses in the same command. (All new-tabs are handled by the old window, maybe
because of the time it takes for the new window to appear. As far as I'm
concerned that behavior is Just Fine and it's probably what most people would
want anyway.)

Might it be worth putting both clauses in the same try { } clause? I don't think
it makes any difference functionally, really just a question of which style
benjamin prefers.

If you need another reviewer (or benjamin is too busy) I'd be happy to stamp it.
Attachment #192608 - Flags: first-review?(benjamin)
Attachment #192608 - Flags: first-review+
Attachment #192608 - Flags: approval1.8b4?
Checked in on trunk.

Checking in nsBrowserContentHandler.js;
/cvsroot/mozilla/browser/components/nsBrowserContentHandler.js,v  <-- 
nsBrowserContentHandler.js
new revision: 1.13; previous revision: 1.12
done
Attachment #192608 - Flags: approval1.8b4? → approval1.8b4+
1.8 Branch:

Checking in nsBrowserContentHandler.js;
/cvsroot/mozilla/browser/components/nsBrowserContentHandler.js,v  <-- 
nsBrowserContentHandler.js
new revision: 1.12.2.1; previous revision: 1.12
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta4
Component: XRE Startup → Startup and Profile System
QA Contact: nobody → startup
You need to log in before you can comment on or make changes to this bug.