If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Changing a bookmark's description changes all descriptions of bookmarks if they previously had them

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Bookmarks
--
critical
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Daniel Aleksandersen, Assigned: Simon Fraser)

Tracking

({dataloss, regression, verified1.8})

unspecified
Camino0.9
PowerPC
Mac OS X
dataloss, regression, verified1.8

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050715 Camino/0.9a2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050715 Camino/0.9a2

I was just editing a description for ONE of my bookmarks and then they all
changed. Don't know why, when or what the f*, but they all changed. See a
screenshot of my bookmarkslist (as soon as I noted that once I changed on
bookmarks description, they all changed).

Can't reproduce.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Screenshot at http://img280.imageshack.us/my.php?image=version200507150809a21kc.png
I can confirm this behavior.

Steps to reproduce:
1. Create a description in one of your bookmarks
2. Go and create a description in another bookmark (closing the panel when finished)
  -> At this point, you should see all your descriptions disappear
3. Create a third description in a third bookmark (closing the panel when finished)
  -> You should see all the bookmark descriptions *reappear* but all with the
same description. 

This isn't hard to reproduce, but it can cause major dataloss.

This must be a regression, when did it happen?

Targeting for 0.9, upping to "blocker" and CCing Simon/Bruce.
Severity: critical → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss, regression
Target Milestone: --- → Camino0.9
Updating summary... longer but more reflective of what's going on.
Summary: changeing one bookmark change em all → Changing a bookmark's description changes all descriptions of bookmarks if they previously had them
Severity: blocker → critical
(Assignee)

Comment 4

12 years ago
Weird.
Assignee: pinkerton → sfraser_bugs
(Assignee)

Comment 5

12 years ago
This happens because when you change the description of a bookmark via the info
panel, the bookmark gets the address of the mutable string storage of the
NSTextView; we need to make a copy.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

12 years ago
Fixed on trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(In reply to comment #6)
> Fixed on trunk and branch.

Bonsai does not seem to show a trunk check-in for this.
(In reply to comment #7)
> (In reply to comment #6)
> > Fixed on trunk and branch.
> 
> Bonsai does not seem to show a trunk check-in for this.

http://tinyurl.com/akwh3 shows checkins for both.  Check that your bonsai query
leaves the "Branch" field empty to see both branch and trunk checkins.

Updated

12 years ago
Keywords: fixed1.8

Updated

12 years ago
Keywords: fixed1.8 → verified1.8
Blocks: 328185
Created attachment 213555 [details] [diff] [review]
Patch for 1.7 Branch

This is a patch for the 1.7 branch.

Note that these changes aren't necessary because this issue didn't actually exist on that branch, so this was more for fun than anything else (and because I just realized that the bug didn't exist). Since it is code cleanup, it'd be nice to have, but again, not necessary.
Attachment #213555 - Flags: superreview?
Attachment #213555 - Flags: review?(alqahira)
Attachment #213555 - Flags: superreview? → superreview?(sfraser_bugs)
Comment on attachment 213555 [details] [diff] [review]
Patch for 1.7 Branch

This doesn't build.  Since the bug doesn't actually exist in 0.8.4 (ooops), we'll drop this from the list.
Attachment #213555 - Attachment is obsolete: true
Attachment #213555 - Flags: superreview?(sfraser_bugs)
Attachment #213555 - Flags: review?(alqahira)
Attachment #213555 - Flags: review-
No longer blocks: 328185
You need to log in before you can comment on or make changes to this bug.