URL bar is not accessible

RESOLVED WORKSFORME

Status

()

Firefox
Disability Access
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Louie Zhao, Assigned: Aaron Leventhal)

Tracking

({access})

Trunk
x86
Linux
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
When focusing and typing in URL bar, only "CBO Location" is read by gnopernicus.
The content in URL bar and the actions in URL bar (typing and selecting) are not
read by gnopernicus. The accessible for URL bar is designed to be "Combo Box" on
Unix, which makes URL bar is not accessible.
(Assignee)

Updated

12 years ago
Blocks: 333488
(Assignee)

Comment 1

12 years ago
Will -- is this problem visible with Orca in current nightly builds? Or should this be closed.

Comment 2

12 years ago
I see some oddities with Orca and the location bar, but typing and navigating seem to speak.  This particular bug is for Gnopernicus, though, so maybe it's not getting the events it needs?

Comment 3

12 years ago
If I move the focus from the URL bar to the next object from the window and then I go back to the URL bar (Shift+Tab), the URL address is selected, but not reported by Gnopernicus. 
(Assignee)

Comment 4

12 years ago
os@baum (sorry don't know your name) -- what should ATSPI be telling you differently? What are you asking us to fix?

Comment 5

12 years ago
The problem is that AccessibleText_getTextAtOffset returns 0 for both startOffset and endOffset (for line start and line end) in the case presented in comment #3.
(Assignee)

Updated

12 years ago
Assignee: Louie.Zhao → gaomingcn
(Assignee)

Comment 6

12 years ago
Mike, I think you'll need to run Gnopernicus and watch what happens in the getTextAtOffset call that happens when you shift+tab back to the URL bar. Why is it returning 0 for endOffset -- presumably it should be returning the end of the line for that.

Comment 7

12 years ago
Yes. I have installed gnopernicus on my fc5 box and am debuging.
(Assignee)

Updated

12 years ago
Keywords: access
(Assignee)

Comment 8

12 years ago
Mike, what's the progress report on this one?

Comment 9

12 years ago
Hi, os@baum.ro,
nsAccessibleEditableText::GetTextAtOffset() is not called when I move the focus to url bar with gnopernicus opened. "Tool bar" is read.  nsAccessibleText::GetTextAtOffset neither, I guess you mean nsAccessibleEditableText in comment#5?
(Assignee)

Comment 10

12 years ago
Removing from dependency list for Firefox 2.
No longer blocks: 333488

Comment 11

12 years ago
When move the focus to url bar, AccessibleText_getTextAtOffset is called by get_text_range_from_offset() function from gnopernicus/srlow/libsrlow/SRObject.c file. The start_range and end_range values for AccessibleText_getTextAtOffset are 0 in this case, which is not ok since the line end of the selected text from the url bar is bigger than 0.
(Assignee)

Comment 12

12 years ago
os@baum.ro -- are you set up to be able to debug where the call dies? Do you build the atk/at-spi infrastructure code? We're not getting the gettextatoffset call in Mozilla.
(Assignee)

Updated

12 years ago
Assignee: gaomingcn → aaronleventhal

Updated

11 years ago
Blocks: 374212
(Assignee)

Comment 13

11 years ago
os@baum -- is this still a problem?
(Assignee)

Comment 14

11 years ago
I'm not sure why this is marked as blocking Orca.

os@baum -- is this still a problem for you in Firefox 3 builds?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

(Assignee)

Updated

11 years ago
No longer blocks: 374212

Comment 15

11 years ago
This bug is not reproducible any more, it works fine for me.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.