"Bookmark All Tabs" in bookmarks menu can be dragged

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
"Bookmark this Page" and "Manage Bookmarks" can't be dragged, so that one should
not be dragged also.
It more or less happens because that menu-item has an id, so removing that id
would disable the dragging.
Although it is rather odd that this depends on the existence of an id.
Maybe it would be better to check for a nodrag attribute or something.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050816
Firefox/1.0+ ID:2005081610
Confirmed on branch
(Reporter)

Comment 2

12 years ago
See:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/bookmarks/content/bookmarksMenu.js&rev=1.48&root=/cvsroot#670
which I think is part of the code that is involved here.
(Reporter)

Comment 3

12 years ago
Well, this is fixed somehow, no idea how or when it was fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.