Display non- ISO-8859-1 characters natively in location bar

RESOLVED DUPLICATE of bug 366797

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 366797
12 years ago
10 years ago

People

(Reporter: Brice Ruth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
In developing sites for countries with very foreign character sets (Russian,
Japanese, etc.) - it would be awfully nice if the QUERY_STRING were displayed as
native characters.

Safari 2.x does this.

Current behaviour: go to http://www.fiskars.com/RU, click on Товары для дома,
and the URL you get is as seen above.

Desired behaviour: go to http://www.fiskars.com/RU, click on Товары для дома,
and get the following URL:

http://www.fiskars.com/RU/Товары+для+дома

It seems arbitrary that ISO-8859-1 (or some other non-Unicode charset)
characters display natively, whereas other characters do not.

Firefox should display the native characters in the QUERY_STRING regardless of
how the URL is encoded in the page, or typed into the Location bar.

Comment 1

10 years ago
2 years and nobody has worked on this. Its really crippling useablity

Comment 2

10 years ago
Could you try with a current Trunk nightly build now that some work has been done in Bug 366797?

Comment 3

10 years ago
Tested and fixed. Thank you so much !

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366797
You need to log in before you can comment on or make changes to this bug.