Combobox "selected" item dynamic change does not work.

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
12 years ago
12 years ago

People

(Reporter: Rados³aw Grzanka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050821 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050821 Firefox/1.6a1

Hello,
While developing my page I have encountered the problem that dynamically changed
"selected" option does not work. 

It breaks some dynamic web applications.(i.e. those which uses javascript reload)

( 
ahcProcedure described below works in IE.

Reproducible: Always

Steps to Reproduce:
1.Consider following snippet:
<select name="foo">
  <option value="one" selected="selected">One</option>
  <option value="two">Two</option>
</select>

<input value="12345"></input>

2. Save it on your hd
3. Open it in browser
4. Now in some text editor change selected option to "Two"
5. Save it
6. Press Ctrl+R in browser

(Optional)
... Change value of input widget in html file. Reload. It works. It works until
user writes there something on his own.
Actual Results:  
Selected option didn't change and still is "One".

Expected Results:  
Selected option should be "Two" unless user explicitly change it (to be
consistent with other widgets. However IE behaves diffrent).

Comment 1

12 years ago
Duplicate of Core bug 46845?
(Reporter)

Comment 2

12 years ago
I have browsed through comments on bug 46845 (sorry.. no time for detailed
reading.). I still think Firefox behaviour is inconsistent. You can change value
of text field upon reload (presumably by some server side scripting language. In
my case JSP/struts/JSTL etc.) until user writes something on his own and you
can't change combobox value even if user doesn't change the value on his own.

Current workaround I did is using javascript snippet afetr every combobox I
render on page. It is not very convienient and makes pages bulky. :/.
uC
C

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 4

12 years ago
*** Bug 320848 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.