Scrollbar flies off into space when child movement inits scroll..

VERIFIED DUPLICATE of bug 34218

Status

()

Core
Layout
P3
major
VERIFIED DUPLICATE of bug 34218
19 years ago
18 years ago

People

(Reporter: Robert Crawford, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If a child moves 'offscreen' of a overflow:scroll parent, clip occurs 
correctly but scroller fails to update in size.
When this unsized scrollbar is shifted, it slides to extend beyond its 
container.
Also, if child is then moved back to orig position(by clicking 
appropriate button in example), 
1)parent does not reflow  and 
2)parent client-area becommes corrupt (different bug, I think...)
This did not happen in the M-13 alpha release...
This can be seen at http://www/w3cdom.com/ex_css2a.html.
(I'm submitting this to 'layout'  is this correct?)

Comment 1

19 years ago
This is a gfx scrollbar problem. If I look at the page using native scrollbars 
on NT, then it behaves as expected and the scrollbars work properly
Assignee: troy → evaughan
(Reporter)

Comment 2

19 years ago
Interesting re: native vs gfx scrollers...
Native scrollers work okay.
Gfx scrollers also cause the scrolling <div>'s border to be ignored in the 
example listed...
(Reporter)

Comment 3

19 years ago
running 2000030913 on NT4...
Scroller widget now updates correctly...
 but the div's border is still missing when gfx-scrollers are used (present when 
using native...)Is this a different big?
(Reporter)

Comment 4

19 years ago
FWIW:
the "gfx makes border diasppear" seems to be bug #23806

Comment 5

18 years ago
reporter - are you still seeing this on new m15 builds? Seems to have been fixed.

thanks

Comment 6

18 years ago
(First -- ignoring the prior reference to an unrelated bug which turns out
to be bug #23806 "no borders on absolutely positioned, overflow:scroll divs")

Second: for this bug -- the original report doesn't seem to apply anymore, but
this does exhibit a  nice testcase for bug #34218 "Scrollbar leaves traces of 
itself as it shrinks". marking as dupl and stealing modified testcase.

*** This bug has been marked as a duplicate of 34218 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Marking verified dup of 34218.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.