Compose Mail in separate window doesn't load anymore at gmail

VERIFIED FIXED in mozilla1.8beta4

Status

()

Core
DOM
--
major
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: mrbkap)

Tracking

({fixed1.8, regression})

Trunk
mozilla1.8beta4
fixed1.8, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b4 +
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
To reproduce, visit Gmail
- Click on Compose Mail
- Now at the right of the page, you can click on the icon that opens the Compose
Mail in a new window. That doesn't work currently in trunk builds.
You don't get the Compose Mail page in the new window. The new window stays
blank or is stuck with the 'Loading..' text.

This works in 2005-08-15, but fails in 2005-08-16:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-15+08%3A00%3A00&maxdate=2005-08-16+08%3A00%3A00&cvsroot=%2Fcvsroot
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050823
Firefox/1.0+ ID:2005082311

Confirmed on Branch
Flags: blocking1.8b4?

Updated

13 years ago
Assignee: general → jst
Flags: blocking1.8b4? → blocking1.8b4+

Updated

13 years ago
Keywords: qawanted

Updated

13 years ago
Flags: blocking1.8b5+
This was indeed caused by the fix for bug 303267. If I pull by date just after
that fix landed and back out the changes to nsGlobalWindow::GetLocation() the
compose window works again. Oddly enoug the changes to that method were backed
out by the fix for bug 304882, but something else apparently changed in (or
between) those two fixes that makes the compose window still not work...
Reassigning to mrbkap who landed those changes...
Assignee: jst → mrbkap
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → mozilla1.8beta4
(Assignee)

Comment 4

13 years ago
This would have been fixed by the checkin (currently trunk-only) for bug 304882,
but the fiasco in bug 292731 caused this to stay broken, even after that check
in. Now that that bug's fixed, I can no longer reproduce this one, marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 292731, 304882
Resolution: --- → FIXED
(Assignee)

Comment 5

13 years ago
This was also fixed on MOZILLA_1_8_BRANCH, marking as such (see comment 4).
Keywords: fixed1.8
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
Gecko/20050826 Mozilla/1.0 (SeaMonkey) and today's _trunk_ Ffox builds on
Windows XP.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.