Display error (elements jumps around) when hide/show DIV using javascript (style.display = ...) to change CSS style

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Justin Hawkwood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

http://www.boxorox.com/webdesign/examples/artsale/index2.html 
What should happen: when mousing over small images at bottom, large image
changes (along with text) to match smaller image, but smaller images SHOULD NOT
MOVE. In Safari 2 (Mac OS X) and IE 6 (Windows 2000) this works as expected:
large image changes, smaller images do not move.  In FireFox (1.0.6 for both)
large images changes as expected, but smaller images jump around as follows:
After load, if mouse over left small image, all small images move down about
1em; When mousing over left then center then right, small images move down by a
large amount (height of image?).

Reproducible: Always

Steps to Reproduce:
1.Load page http://www.boxorox.com/webdesign/examples/artsale/index2.html 
2.Mouse over (from above) left small image (small images jump down about 1em)
3.Mouse from left to right across all small images (small images jump down
significantly)

Actual Results:  
Small images move vertically, first a small amount, then a large amount

Expected Results:  
Small images should not move at all.

Comment 1

13 years ago
See http://www.mozilla.org/support/firefox/bugs.  I believe this paticular bug
has already been fixed.  If you can't reproduce this in a current nightly,
please resolve this bug WORKSFORME.
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.