External DTD is not loaded, thus Mozilla Firefox is unable to replace the entities

RESOLVED DUPLICATE of bug 22942

Status

()

--
major
RESOLVED DUPLICATE of bug 22942
13 years ago
13 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/312.1.1 (KHTML, like Gecko) Safari/312
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

At the location: http://xistence.breached.x-istence.com:81/XML%20and%20XSLT/guidetest/
sampleguide.xml

The external DTD should be loaded, and parsed together with the XML page. It is currently not parsing 
it, because the entity does not exist for some reason. FireFox seems to be able to load the XHTML 
doctype though, as it does replace © when used in an XSL stylesheet. Also, because it is unable to 
parse the DTD, certain XPointer links will not work now, and not in the future unless this gets fixed.

I have set severity to major, as without this support, the future for client side XSLT parsing looks bleak.

Reproducible: Always

Steps to Reproduce:
1. Goto http://xistence.breached.x-istence.com:81/XML%20and%20XSLT/guidetest/sampleguide.xml
2. Look at the glorious error!
3.

Actual Results:  
Gave me an error.

Expected Results:  
It should have loaded the external DTD, and cached it just like it would have cashed any other 
document. It should then have parsed it using the XML parser, and it should have noticed that the entity 
does exist.

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: External DTD is not loaded, thus Mozilla FireFox is unable to replace the entities → External DTD is not loaded, thus Mozilla Firefox is unable to replace the entities
You need to log in before you can comment on or make changes to this bug.