Last Comment Bug 305975 - Height:0% is not the same as height:0px inside a table
: Height:0% is not the same as height:0px inside a table
Status: RESOLVED FIXED
: fixed1.8, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 2 votes (vote)
: mozilla1.8beta5
Assigned To: Bernd
:
Mentors:
http://distrowatch.com/
: 293372 (view as bug list)
Depends on: 323459
Blocks: 271387
  Show dependency treegraph
 
Reported: 2005-08-25 14:58 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2007-03-12 05:21 PDT (History)
5 users (show)
asa: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (915 bytes, text/html)
2005-08-25 14:59 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
patch (1.47 KB, patch)
2005-08-27 12:56 PDT, Bernd
bzbarsky: review+
bzbarsky: superreview+
asa: approval1.8b5+
Details | Diff | Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2005-08-25 14:58:21 PDT
See upcoming testcase.
Both tables and button inside it are identical, only the first has height:0% and
the second has height:0px.
They should render the same, but they don't.

I saw this when looking at distrowatch.com.

bz	{#developers} mw22: oh, tables....
bz	{#developers} mw22: hrm... file a bug? ;)
bz	{#developers} mw22: and make sure to cc bernd...
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-08-25 14:59:46 PDT
Created attachment 193855 [details]
testcase

The bug can also be seen in Mozilla1.7.
Comment 2 Worcester12345 2005-08-26 06:52:12 PDT
Is this feature any part of the "Acid 2" test?
Comment 3 Bernd 2005-08-27 12:25:24 PDT
the percent height observer stuff is obviously not limited to quirks mode as it
should be. The questions is only where to cut it.
Comment 4 Bernd 2005-08-27 12:56:13 PDT
Created attachment 194052 [details] [diff] [review]
patch

cut it at the cell level where it seems to start.
Comment 5 Bernd 2005-08-28 00:02:09 PDT
>Both tables and button inside it are identical, only the first has height:0% and
>the second has height:0px.
>They should render the same, but they don't.
They should not render identical in standards mode a percentage base height
inside auto height becomes itself auto. So its height: auto vs 0px.
Comment 6 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-08-28 03:19:46 PDT
Ah, I see. So the patch seems to fix http://www.distrowatch.com broken layout
(because distrowatch is in standards mode).
The mentioning of the broken layout at distrowatch.com (buttons and stuff
overflowing table cells) was here:
http://forums.mozillazine.org/viewtopic.php?p=1704044
Comment 7 amano 2005-08-28 15:44:11 PDT
Maybe this should be chosen for the branch. If it is  not a risky patch, then
please nominate it. 
Comment 8 Bernd 2005-08-30 10:26:49 PDT
fix checked in
Comment 9 sbporter 2005-08-31 11:58:42 PDT
"The set of bugs blocking beta1 is tracked by the blocking1.8b4 flag . This list
is the set of bugs which truly have to be done before a more public release.
These are large/risky patches, common crashes, or break commonly used websites."
http://developer.mozilla.org/devnews/index.php/2005/08/30/9-days-untill-15-beta/

This would seem to fit in the "broken commonly used websites" (assuming that is
what they meant to say) category, could this possibly be checked into the branch?
Comment 10 Asa Dotzler [:asa] 2005-09-13 10:14:23 PDT
bernd, bz, is this branch worthy?
Comment 11 Boris Zbarsky [:bz] (Out June 25-July 6) 2005-09-13 11:53:40 PDT
Comment on attachment 194052 [details] [diff] [review]
patch

I believe it is, yes.  This makes a table quirk only happen in quirks mode. 
Only standards-mode stuff is affected, and probably only for the better.
Comment 12 Boris Zbarsky [:bz] (Out June 25-July 6) 2005-09-14 15:55:27 PDT
*** Bug 293372 has been marked as a duplicate of this bug. ***
Comment 13 Boris Zbarsky [:bz] (Out June 25-July 6) 2005-09-16 12:53:46 PDT
Fixed on branch.

Note You need to log in before you can comment on or make changes to this bug.