If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

win32: Crash running profile manager 2nd time

VERIFIED DUPLICATE of bug 30666

Status

()

Core
XPCOM
P3
blocker
VERIFIED DUPLICATE of bug 30666
18 years ago
9 years ago

People

(Reporter: gayatrib, Assigned: Suresh Duddi (gone))

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The crash is in today's build .
Steps to reproduce:

I start apprunner (delete mozRegistry first)
I bring up the profile manager and run the create profile wizard.
First pass goes thru fine.
The second time I run it (in the same session), I crash.


Here is the stack trace.


nsComponentManagerImpl::ProgIDToClassID(nsComponentManagerImpl * const
0x010a4360, const char *
0x100b48b4, nsID * 0x000330b8) line 1139
nsComponentManager::ProgIDToClassID(const char * 0x100b48b4, nsID *
0x000330b8) line 59
nsServiceManagerImpl::GetService(nsServiceManagerImpl * const
0x010a46d0, const char * 0x100b48b4,
const nsID & {...}, nsISupports * * 0x00033128, nsIShutdownListener *
0x00000000) line 429 + 13 bytes
nsServiceManager::GetService(const char * 0x100b48b4, const nsID &
{...}, nsISupports * * 0x00033128,
nsIShutdownListener * 0x00000000) line 545
nsGetServiceByProgID::operator()(const nsID & {...}, void * *
0x00033128) line 63 + 22 bytes
nsCOMPtr<nsIObserverService>::assign_from_helper(const nsCOMPtr_helper &
{...}, const nsID & {...}) line
795 + 18 bytes
nsCOMPtr<nsIObserverService>::nsCOMPtr<nsIObserverService>(const
nsCOMPtr_helper & {...}) line 498
nsEventQueueImpl::NotifyObservers(const char * 0x100b4698) line 166 + 33
bytes
nsEventQueueImpl::~nsEventQueueImpl() line 84
nsEventQueueImpl::`scalar deleting destructor'(unsigned int 1) + 15
bytes
nsEventQueueImpl::Release(nsEventQueueImpl * const 0x03062080) line 139
+ 120 bytes
nsCOMPtr<nsIEventQueue>::~nsCOMPtr<nsIEventQueue>() line 435
nsAppShellService::Observe(nsAppShellService * const 0x0143a0a4,
nsISupports * 0x03062080, const
unsigned short * 0x00041f28, const unsigned short * 0x00000000) line 759

nsObserverService::Notify(nsObserverService * const 0x0143b8a0,
nsISupports * 0x03062080, const unsigned
short * 0x00041f28, const unsigned short * 0x00000000) line 241
nsEventQueueImpl::NotifyObservers(const char * 0x100b4698) line 169
nsEventQueueImpl::~nsEventQueueImpl() line 84
(Reporter)

Updated

18 years ago
Keywords: beta1

Updated

18 years ago
Summary: win32 crash. → win32: Crash running profile manager 2nd time
I am not seeing this with Gayatri's changes added to my tree which was pulled 
last night (3/4). Whatever's causing this seems likely to have been added 
today.

Comment 2

18 years ago
This looks related to warren and dougt's changes from this weekend.
(Assignee)

Comment 3

18 years ago
How do I run profile manager the second time in the same session ? I am trying 
to reproduce the problem.

Comment 4

18 years ago
sounds like 30666?  We should mark this as a dup.  If I am wrong reopen please.

*** This bug has been marked as a duplicate of 30666 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Putting on verifyme keyword.
Keywords: verifyme

Comment 6

17 years ago
Adding crash keyword
Keywords: crash

Comment 7

17 years ago
Verified. Not really a dupe of 30666, but running profile manager 2nd time does 
not crash.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.