All users were logged out of Bugzilla on October 13th, 2018

Should fire NS_FOCUSCONTENT event on nsPluginInstanceOwner by clicking plugin's content

RESOLVED FIXED in mozilla1.9alpha1

Status

()

--
major
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: masayuki, Assigned: emk)

Tracking

Trunk
mozilla1.9alpha1
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

When object frame created child widget for plugin content, the events for plugin
conent is catching on nsPluginInstanceOwner class. This class has focus listner.
But this focus listner is fired by using keyborad tabbing. We click prugin content,
the event isn't fired. I need this event for advanced IME implementation(See bug
55751). Please help me.
(Reporter)

Updated

13 years ago
Blocks: 55751
No longer blocks: 5571
Created attachment 194078 [details]
testcase

If base widget of flash plugin has focus, you can show alert.
You can set focus by Keyborad only. You may not be able to set focus by mouse
click.
(Reporter)

Updated

13 years ago
Depends on: 169071
(Reporter)

Updated

13 years ago
Assignee: events → VYV03354
(Assignee)

Comment 2

13 years ago
Created attachment 194246 [details] [diff] [review]
Patch rv1.0

When plug-in window clicked, the messages will be sent in the following order:
1. PluginWndProc
2. WndProc set by plug-ins
3. nsWindow::ProcessMessage
and NS_PLUGIN_ACTIVATE will be generated in nsWindow::ProcessMessage.
But some plug-ins (including Flash Player) won't forward messages to
nsWindow::ProcessMessage. Therefore I moved WM_MOUSEACTIVATE to PluginWndProc.
Attachment #194246 - Flags: superreview?(jst)
Attachment #194246 - Flags: review?(jst)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

13 years ago
*** Bug 243824 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

13 years ago
*** Bug 213466 has been marked as a duplicate of this bug. ***
I tested the patch, it works fine.
Comment on attachment 194246 [details] [diff] [review]
Patch rv1.0

roc:

Could you r+sr for this?
This blocks bug 55751.
I tested this patch. This patch works fine for me.
Attachment #194246 - Flags: superreview?(roc)
Attachment #194246 - Flags: superreview?(jst)
Attachment #194246 - Flags: review?(roc)
Attachment #194246 - Flags: review?(jst)
Comment on attachment 194246 [details] [diff] [review]
Patch rv1.0

This is a risky patch. Make sure it only lands on trunk!
Attachment #194246 - Flags: superreview?(roc)
Attachment #194246 - Flags: superreview+
Attachment #194246 - Flags: review?(roc)
Attachment #194246 - Flags: review+
checked-in. thank you.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha
Created attachment 196510 [details] [diff] [review]
Patch for check-in

Updated

13 years ago
Blocks: 323142

Comment 10

13 years ago
I'm proposing that we back out this fix because it has caused bug 323142 and reopen this bug.
Is it possible to fix this bug in a similar way to the way bug 317486 was fixed?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ian:

Don't reopen this bug until the patch is backed out.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Comment 12

13 years ago
We might need both handlers or something to satisfy all needs.
*** Bug 356554 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.