"Save link as..." of javascript (*.js) file hangs when downloading

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: nbauer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Right-clicking on the "the js file" link and selecting "Save Link As..." Seems
to begin downloading and the DL Manager opens, but it hangs and doesn't finish.
Clicking on the link normally displays the contents of the file as expected.

Reproducible: Always

Steps to Reproduce:
1. Right-click on "the js file" hyperlink 
2. Select "Save Link As..." and select a download location.
3. Watch as the DL Manager opens up and nothing happens.

Actual Results:  
The DL Manager looks like it's downloading, but the "amount downloaded" never
increases much. Only option is to cancel the download.

Expected Results:  
As in IE, it should download near-instantly

Comment 1

13 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050826
Firefox/1.0+

Try clearing the downloaded files cache.
http://www.mozilla.org/support/firefox/options#privacy If this solves your
problem please let us know by making a note in this bug.
(Reporter)

Comment 2

13 years ago
After clearing the cache, it worked. However, I noticed that the problem
returned after mousing-over the menu, which uses the same *.js file to work.
Now, the Download Manager says it has downloaded 3K at ___ kb/s, in it's
"downloading, total size unknown" state perpetually. After clearing the cache
but prior to activating the script by mousing-over the menu, the file downloads
just perfectly.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050829
Firefox/1.0+ ID:2005082911

->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.