input type="file" component does not preserve Unicode characters in filenames when selecting files from the 'browse' file selector

RESOLVED DUPLICATE of bug 162361

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 162361
13 years ago
13 years ago

People

(Reporter: Andrew Millband, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Experienced on a closed web site advertising jobs in Japan and reproduced on:

http://www.animalpicturesarchive.com/uploadImg.php
http://www.computerweekly.com/Jobs/CVAdvice.aspx

On any html page that allows file uploads like those above if you select a file,
from the 'Choose File' dialog that contains unicode characters in the filename
then those characters are replaced with '_'. This prevents the selected file
being uploaded.

Reproducible: Always

Steps to Reproduce:
1. Goto: http://www.animalpicturesarchive.com/uploadImg.php (or any HTML page
with a file upload component)
2. Click the browse button (this opens the "Choose File" dialog)
3. Select a file which has unicode characters in its name (japanese characters
are always good!)
4. Click open.
5. Check the file path displayed in the file upload text box.
6. Submit the form.

Actual Results:  
After Step 4. the path to the file is displayed with unicode characters replaced
with '_'. 

After Step 6. a 0kb sized file with name the substituted name is submitted.

Expected Results:  
After Step 4. the path to the file should have been displayed including any
unicode characters.

After Step 6. the file referenced by the path is submitted/uploaded.

If you type the filename with unicode characters in manually then the upload
component submits the file as expected.

Comment 1

13 years ago
I'

*** This bug has been marked as a duplicate of 162361 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.