Closed Bug 306349 Opened 15 years ago Closed 14 years ago

Adding horizontal padding to the anonymous div inside a textarea breaks RTL textareas

Categories

(Core :: Layout, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: uriber, Assigned: roc)

References

()

Details

(4 keywords)

Attachments

(1 file)

Steps to reproduce:

1. Add the following rule to your userContent.css file:
textarea > .anonymous-div
{
  padding: 0px 2px;
}
2. (Re)open Firefox/SeaMonkey.
3. Open any page with an RTL textarea, such as
https://bugzilla.mozilla.org/attachment.cgi?id=128683
4. In the RTL textarea, type or delete characters.

You will notice that a horizontal scrollbar will appear, and its slider will
constantly shrink (meaning the textareas logical width increases) as you type
and delete. Notice that typing will never cause the text to wrap, because the
line will just keep getting longer.

This regressed between 2005-04-28 and 2005-04-29, likely due to fixing bug
240276 (although the behavior has slightly changed since then, in terms of where
the text scrolls to).

Note that such setting of padding currently exists by default in Camino, causing
bug 304609. Also, adding such padding for Firefox/SeaMonkey is a way of fixing
bug 233348.
Summary: Adding horizontal padding to the anonymous div inside a textarea breaks RTL textareas → Adding horizontal padding to the anonymous div inside a textarea breaks RTL textareas
if this gets patched and landed on the trunk and verified, please renominate for
the branch.
Flags: blocking1.8b4? → blocking1.8b4-
bz - care to have a look at this?
Maybe, but it won't happen for several weeks at least no matter what I want.  In
any case, my money is on poor interaction between the XUL layout of the input
itself and the HTML layout of the div inside...
Blocks: 240276
Attached patch fixSplinter Review
Uri, can you test this? It seems to fix the problem for me. There's still the
problem that if you add an unbreakable word so a horizontal scrollbar must
appear, and then delete the word, the scrollbar is still there (in other words,
the scrolled content can't get narrower). But I believe that bug has always
been around. Thanks!
Assignee: nobody → roc
Status: NEW → ASSIGNED
Nope - this doesn't help (behavior is just as it was without the patch).
Putting a breakpoint on that line, I can see that |paddingLR| is 0 when it's
reached (in a textarea with a padded anonymous div).
Depends on: 312550
This was fixed by the patch for bug 312550.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
v.fixed on 1.8.0.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060104 Firefox/1.5.0.1, typing/deleting in RTL textbox appears to work as expected with the steps in comment #0.
Keywords: verified1.8.0.1
Keywords: fixed1.8.0.1
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.