On a clean Windows 95 install installer crashes

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: fisher7, Assigned: ssu0262)

Tracking

({crash})

Trunk
x86
Windows 95
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I thought I'd try installing mozilla on a bare Win95 install...

Steps to reproduce:
1.  Do a clean install of Win95 B
2.  Run the M14 installer
3.  Click next, next, next, install
4.  Install outputs "Preparing install, please wait..."
5.  It then comes up with a dialog that reads: Error 1157: Could not load c:\windows\temp\core.ns\bin\xpistub.dll

I also tried with the latest M15 installer build (3/5/00), the results were identical.

Note:  I also tried the zipped M14 and the zipped M14 with talkback on this bare Win95 B install.  Both failed to run and returned "A required .DLL file MSVCRT.DLL, was not found."
(Assignee)

Comment 1

19 years ago
Looks like we regressed.  This was fixed at one point.  I'm trying to confirm 
this bug now.
(Assignee)

Comment 2

19 years ago
Jan, do you know where we might be able to find a clean win95B system around?  
Or at least where we might be able to install such an OS?

If it is indeed that it does not come with msvcrt.dll (the second part of this 
bug), we need to do something to the installer to install it.  I'm also thinking 
that this missing file might be what's causing the first part of this bug too.

We could have the installer just install the msvcrt.dll and msvcrti.dll files 
when they are not found on the system.

fisher7, can you do a search of your entire hard drive to see if there are any 
copies of msvcrt.dll that might have strayed from the "normal" dll search path 
(essentially anywhere on your hard drives[s])?

Comment 3

19 years ago
Sean,
Unable to reproduce on my Win95 machine, will do some checking on what caused 
this before.

Grace
We need a machine no one cares about so we can restore from a CD.  I have a 
Win95a CD for an HP Pavilion, don't know if it will work on a non-HP machine 
though.

Comment 5

19 years ago
I have a box we can wack it with a clean os install...  working on getting the 
machine set up.  I am assuming that win95B is their OSR-2 (OEM Service Release 
2) build.
(Reporter)

Comment 6

19 years ago
cathleen@netscape.com: yes, you assume correctly that by Win95B I meant the OSR-
2 build, sorry for any confusion.

ssu@netscape.com: Since I did the clean install of 95B, I installed other 
software which made this bug go away on my machine (IE 5.01).  But, from 
memory, right after the clean install a search for msvcrt.dll returned 
nothing.  The closest matches were msvcrt20.dll, and msvcrt40.dll both in the 
c:\windows\system directory. I just did a search now and it looks like 
msvcrt.dll is in place right next to the msvcrt20.dll, msvrc40.dll.  I'm pretty 
sure it was IE 5.01 that installed it (msvcrt.dll that is).

cathleen@netscape.com: That's awesome that you're setting up a machine to test 
this.  Any chance that it could be used to test bug 27601?  A clean install of 
95B is exactly what's needed to reproduce 27601. And netscape people 
(leger@netscape.com, jrgm@netscape.com, and dp@netscape.com) have been saying 
they want to reproduce 27601 "in house."

Comment 7

19 years ago
Adding crash keyword.
Keywords: crash

Comment 8

19 years ago
This bug is fixed in PR1 build.

There were some system DLLs that we depend on are missing in clean 
Win95/win95 B install.

See bug 32340
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
agree
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.