If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Memory-Leak when opening oversized GIF-Image.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Melanie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; de) Opera 8.01
Build Identifier: Firefox 1.0.6 [de] and other

Everytime trying to view the given image, Firefox crashes my system by 
allocating all memory (about 10MB per second).

The same error is present in Netscape 7.02. Opera and IE displays the image 
without problems - without memory leaks.

Not every systems seems to be affected, since there are users that can view this 
image without having trouble.

See also German-Firefox-Forum:
http://www.firefox-browser.de/forum/viewtopic.php?
t=24051&postdays=0&postorder=asc&start=0

Reproducible: Always

Steps to Reproduce:
1. Open the image in Firefox or Netscape and look at Taskmanager for memory-
usage.
2.
3.

Actual Results:  
In Firefox my system totaly crashes. I have to do a hard reset. Even Ctrl-Alt-
Del doesn't work.
In Netscape 7.02, memory usages rises as in Firefox, but stops at about 100MB. 
System still responds.

Expected Results:  
Error-handling for oversized or damaged images. IE or Opera 8.01 don't have 
problems with memoryleaks while opening this image. If Image is too big, it 
should not be displayed.

Comment 1

12 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050831
Firefox/1.0+

Comment 2

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050831
Firefox/1.0+ gives a big memory  (about 100Mb) but this settles back again after
a second or two.  No crash.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050901
Firefox/1.0+ ID:2005090112

This works in what will become FF1.5

->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 4

12 years ago
The problem is still in the very last firefox release (the 1.5.0.1 version or may be the 1.8.0.1 it depends on the way of numbering that I don't understand :( ) (but not in mozilla suite) 
just try http://facs.scripps.edu/surf/images/euranim.gif
REOPEN

Comment 5

11 years ago
REOPEN

Comment 6

11 years ago
(In reply to comment #4)

> just try http://facs.scripps.edu/surf/images/euranim.gif

Sounds like bug 126445.

Comment 7

11 years ago
(In reply to comment #4)
> The problem is still in the very last firefox release (the 1.5.0.1 version or
> may be the 1.8.0.1 it depends on the way of numbering that I don't understand
> :( ) (but not in mozilla suite) 
> just try http://facs.scripps.edu/surf/images/euranim.gif
> REOPEN
> 

no problem in Firefox 2.0 beta 2

Comment 8

11 years ago
I haven't anymore problems with this picture http://www.lajollasurf.org/images/euranim.gif
with firefox last release :
Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
You need to log in before you can comment on or make changes to this bug.