Closed Bug 306754 Opened 17 years ago Closed 16 years ago

QuickTime plugins: only audio, no video when old version of Adblock is enabled

Categories

(Core :: Plug-ins, defect)

1.8 Branch
defect
Not set
normal

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: jo.hermans, Unassigned)

References

()

Details

I'm seeing a regression with the QuickTime 6.5.2 plugin, in the 20050901
version, under both Windows XP and Mac OS X 10.2.8. I have audio, but no video
anymore. Repeatable on various websites. The stand alone player still works,
iTunes too. I would have assumed that it was just a problem with the plugin
itself, but to my surprise I saw it on 2 different OS'es at the same time.

I'm not sure if it's related to the XPCNativeWrapper-change, but it appeared
together with bug 306108 (Content frame empty in chatzilla extension), so bug
302276 (Flip xpcnativewrappers) is suspicious.
Component: General → Plug-ins
Flags: blocking1.8b5?
Flags: blocking1.8b4?
Keywords: regression
Product: Firefox → Core
Version: 1.5 Branch → 1.8 Branch
Flags: blocking1.8b4?
QA Contact: general → plugins
Can someone else reproduce and even debug a bit?

/be
I don't think this problem is tied to quick time. On my windows machine, I think
it's invoking windows media player as a plugin. And I see the same thing. If I
move the window off screen and move it back, I'll get a 'snapshot' of whatever
the current video is showing but while the browser is on screen, we never do any
rendering on the video frame. 

Another way to see it. After the clip has fully downloaded, move the position
slider around. You'll see that when you first let go of the slider, we paint the
first video frame, but nothing else as the clip plays. 
ignore my previous comments. I went to an English site where I could understand
what I was clicking on (cnn.com) and the windows media player plugin played
video content without a problem. 

I'll try to find a site that uses quick time instead of WMP in English next.
Quick time played fine for me too on Windows. 09/01 Build.

http://www.apple.com/trailers/fox/transporter_2/hose.html
If this is a regression, could we get a 24-hour regression range and the dates
and hours for the relevant builds?
I can't verify it as a regression nor provide a regression window yet because I
haven't been able to reproduce it yet. 

Jo, where you using a 1.6a1 build or a 1.0+ branch build? 
(In reply to comment #6)
> I can't verify it as a regression nor provide a regression window yet because I
> haven't been able to reproduce it yet. 
> 
> Jo, where you using a 1.6a1 build or a 1.0+ branch build? 

I'm in the office again, so this report is from my Windows XP computer.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050831
Firefox/1.0+
QuickTime Plug-in 6.5.1

The last version where I'm sure it worked ok was 20050823, but I'll try to
narrow it down later today. Note that I upgraded with 'Check for updates'.
I tested on Windows XP, all branch builds (mozilla1.8 builds)

build 20050829 09:53 ok
build 20050830 09:58 ok
build 20050830 17:42 nok <--
build 20050830 19:45 nok
build 20050831 09:55 nok

Bug 302276 is smack in the middle of the regression window.

I tested on page
<http://www.vrtnieuws.net/nieuwsnet_master/default/nieuws/overzicht/050901Bushspeech/index.html?video_1>,
but you'll have to set a few cookies first, otherwise it will start mediaplayer.
And by default it runs in a narrowband connection, that only shows 1 frame every
4 seconds, but with full audio.

To do this (sorry, that page is in Dutch), click on 'video-instellingen'
(top-right), and then select 'quicktime' and 'breedband'. this will set cookies
in the *.vrtnieuws.net domain. There's a test below ('ja, ik wil een test
zien'), that displays the same error.
Hmm... Does this plugin include some sort of scriptable component?  Does it
access JS?
WFM - Deer Park Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050901 Firefox/1.0+
sorry, that was using QT 6.5.1
both the apple url and vrtnieuws.net work for me in trunk and 1.5 firefox builds
on windows xp although the video on vrtnieuws is slow and choppy. Note I have qt
6.5.2 installed, but when you right click on the plugin display it shows 6.5.1.
I checked the plugins installed in the quicktime folder against those in the
firefox plugins dir and they match.
Another URL that fails, but without cookies or such :
<http://www.apple.com/trailers/paramount/aeon_flux/small.html>

I can repeat this with todays build, both on Windows XP and Mac OS X 10.2.8,
both on the 1.8 branch. The PC was using a proxy-server, the Mac didn't (I say
this because the proxy might interfered with the RTP stream, that's my line of
work).

If it was only visible on a single platform, I wouldn't have reported this, and
I would have assumed it was due to a bad plugin.
Is there anyone seeing this who can make his own builds?  If so, it'd be nice to
track down the exact checkin that caused this...
Oh damn, I got it. It's some kind of interference between Adblock and the
XpcNativeWrappers change.

I was looking thru all the preferences to see what was common between the PC and
the Mac, and then I noticed that they were both using Adblock 0.5.2.039. I
uninstalled Adblock on the Mac, and the problem was solved.

Note that when I double checked on the PC, I noticed that Adblock worked, but
didn't display anything in 'list all blockable elements'. I hope that not a
regression on its own.
Hmm...  Adblock was definitely one of the extensions likely to be broken by
XPCNativeWrapper unless it made some changes...  Perhaps they haven't had a
chance to make those changes yet?
I can reproduce this with (Quicktime 6.5.2 and) Adblock enabled. Workaround is
to disable Adblock in Tools>Adblock>Preferences.

A fixed version of Adblock is available here:
http://aasted.org/adblock/viewtopic.php?t=2264&sid=5c7b4bb21e9c4dd9b93ae614d0d9c265
Summary: QuickTime plugins: only audio, no video → QuickTime plugins: only audio, no video when Adblock is enabled
I agree that this looks to be a problem with adblock and the xpcnativewrappers
to me.  The only time the video from comment #4 did not show for me was after I
installed adblock.  I got the xpi from adblock's home on mozdev and changed the
maxVersion. The problem was that I could hear the audio but there was no visible
 player present to show the video.  Then I edited adblock's chrome.manifest to
add xpcnativewrappers=no to the last line.  Then the video worked again. And
adblock works as it used to.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050902
Firefox/1.0+ ID:2005090207
since this is an extension issue and extensions will need to be revved for 1.5
anyway, not going to block on this.
Flags: blocking1.8b5?
Flags: blocking1.8b5-
Flags: blocking1.8b4?
Flags: blocking1.8b4-
Asa: this is not an extension issue. JEP is the Mac java plugin that we ship
with Firefox. This bug should probably be a blocker for a while while we
investigate. Renominating.
Flags: blocking1.8b4- → blocking1.8b4?
NM - I see you're talking about adblock not JEP. My bad.
Flags: blocking1.8b4?
No problems here with:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050904 Firefox/1.0+
Updated Adblock (comment 17)
Mplayerplug-in 3.05
This appears to be related to the adblocker obj-tabs option... when checked, I
get  audio only, when it is not checked I get both. 
(under tools menu -> adblock -> prefrences -> adblock options -> obj-tabs)
I don't recall haiving this issue in earlier versions of the browser
(current: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050908 Firefox/1.4)
QuickTime Plug-in 7.0.2a63
Definatly having this issue with quicktime, can be reproduced here:
http://www.apple.com/trailers/newline/the_man/theMan320.html
* Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050924
Firefox/1.6a1
* Quicktime 7.0.2

*AdBlock 0.5.2.039 : 
Quicktime audio-only-no-video problem

*Adblock 0.5.2.050 : 
issues with apple.com/trailers page fomatting.
(Has problems with formatting other webpages. ex.www.google.com)

Disabling either version of adblock makes the above issues go away.
Also affected embedded WMP and I'm using the latest Quicktime files from Apple
(7.03)
*** Bug 315365 has been marked as a duplicate of this bug. ***
Adblock is fixed, so get the latest version from https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Popular&numpg=10&id=10

-> WFM.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Summary: QuickTime plugins: only audio, no video when Adblock is enabled → QuickTime plugins: only audio, no video when old version of Adblock is enabled
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.