When printing a page with shaded cells, the second print page is entirely shaded.

RESOLVED DUPLICATE of bug 142062

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 142062
13 years ago
13 years ago

People

(Reporter: Saul Krimsly, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When printing a table which requires more than 1 page to print, where the table
includes a row with shaded cells (e.g., <td align="center" bgcolor="#cccccc"
width="100">4</td>), and where Firefox "Print Background" is turned on
(File/Page Setup/Format & Options: Print Background) the second page is entirely
shaded. I have tested this on multiple printers and computers (Windows 2000 and
XP) with the same result, and this does not occur in IE.

This is somewhat similar to bug report #299303 (Bleeding Background), but
involves different tags.

I do use an imbedded style sheet that includes, "td {font-family: "Arial";
font-size: 7.5pt; line-height: 1.25; vertical-align:top; border:1px solid
silver}", but the cell shading is controlled by the actual cell "td" tags.

An html page which demonstrates this bug is posted at,
http://www.itsolutionz.com/download/help/example_shading_bleed.html

Reproducible: Always

Steps to Reproduce:
See the example page at,
http://www.itsolutionz.com/download/help/example_shading_bleed.html, and review
the source code.



Expected Results:  
As with IE, all pages beyond the first print page should print with the correct
cell shading, rather than having entire pages shaded.

As I use Firefox as a helper program for printing html formatted reports created
by a database front-end, this presents a significant obstacle for report
printing--I have had to go back to IE for multiplag printing:-(
This also occurs in Camino while printing.

-> core for triage
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch

Comment 2

13 years ago
Duplicate of bug 142062?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Duplicate of bug 142062?

You are correct (I did not find that reference when searching the bug list).

I also found a workaround on the list, as follows...Add  white bgcolor to all
BODY tags, as in, <body bgcolor="#ffffff"> your html </body>.
Duping...

*** This bug has been marked as a duplicate of 142062 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.