Last Comment Bug 306881 - fix canvas pattern repeat attribute
: fix canvas pattern repeat attribute
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Vladimir Vukicevic [:vlad] [:vladv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 13:57 PDT by Vladimir Vukicevic [:vlad] [:vladv]
Modified: 2005-09-19 23:51 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix-canvas-pattern-repeat.patch (4.61 KB, patch)
2005-09-02 13:58 PDT, Vladimir Vukicevic [:vlad] [:vladv]
pavlov: review+
asa: approval1.8b5+
Details | Diff | Review

Description Vladimir Vukicevic [:vlad] [:vladv] 2005-09-02 13:57:30 PDT
Right now canvas patterns aren't set to repeat like the should be per the spec.
 This fixes this, and also fixes a late spec change to arc().
Comment 1 Vladimir Vukicevic [:vlad] [:vladv] 2005-09-02 13:58:33 PDT
Created attachment 194697 [details] [diff] [review]
fix-canvas-pattern-repeat.patch
Comment 2 Kamiel Martinet 2005-09-19 11:29:16 PDT
Vladimir,

Changing the arc method to reflect the changes in the spec makes it incompatible
with Safari's implementation. Drawing arcs clockwise or counterclockwise is
completely different and would result in a faulty rendered image in one or the
other.
I don't know what Hixie's reasons where for changing this but this would make it
impossible to write a cross browser script without doing some sort off browser
sniffing.
I would stick with the current solution since that doesn't break anything.
Comment 3 Vladimir Vukicevic [:vlad] [:vladv] 2005-09-19 17:08:34 PDT
It doesn't create an inconsistency, unless I screwed up somewhere; Safari had a
documentation error, whereas their implementation does what this does.  We
agreed with the Safari devs to just change the documentation.
Comment 4 Kamiel Martinet 2005-09-19 23:51:40 PDT
Your absolutely right.

Note You need to log in before you can comment on or make changes to this bug.