Can't read IMAP using SSL

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: buster, Assigned: mscott)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
migrated my 4.x profile
ran mozilla mail for the first time
clicked on the IMAP folder on tintin
mail asked me for my certificate.  I hit OK.
mail asked me for my password.  I typed it in.
crash. twice.
the only way I was able to get into mail was to change the account to not use SSL

Comment 1

19 years ago
there were problems today with a second password dlg coming up. I'm wondering if 
this bug is related:  http://bugzilla.mozilla.org/show_bug.cgi?id=30666

Comment 2

19 years ago
Steve, does this still crash today? If so, could you give a stack trace or
talkback report?
(Reporter)

Comment 3

19 years ago
no crash this morning.  Instead, I can't get into my inbox folder.  The app just 
spins the throbber, but nothing ever shows up in my inbox.  In the console, I 
see:

in showthreads
Before getting inbox
We have an inbox
InboxURI = imap://buster@tintin.netscape.com/INBOX
imap://buster@tintin.netscape.com/INBOX
In ChangeFolderByURI

This is with the "use secure connection (SSL)" option on.

If I turn the SSL option off, I can log in and read mail fine.

Comment 4

19 years ago
Re-summarized bug, assigned to mscott, cc pavlov
Assignee: phil → mscott
Summary: crash trying to open IMAP account → Can't read IMAP using SSL
(Assignee)

Comment 5

19 years ago
Nothing on the imap side has changed at all since we turned imap ssl on. It's
still working for me.

Buster, you are running a commercial build right? Cartman isn't part of the
mozilla build so you won't be able to read your mail via ssl unless you are
using a commercial build.
(Reporter)

Comment 6

19 years ago
no, I was running debug non-commerical build.  Originally, this bug report was a 
crash, which is why I reported it.  Now, it's a UI-never-terminates bug I guess, 
low priority.  We should put up an error message of some sort, shouldn't we?  I 
am a bit nervous that the crash just disappeared.
(Assignee)

Comment 7

19 years ago
Yeah there's a problem where necko just spins forever if you try to create a ssl
connection and it doesn't know how to create that type of connection. I believe
one of those guys has a bug to throw up something. I'll see if I can find it.

I'm going to downgrade the severity of this bug.

If you want to really use imap ssl, use a commercial build. And eventually the
mozilla builds will be shipped with cartman and all will be well there to.

In the meantime, I'll try to find the netwerk bug I'm thinking of and mark this
one a dup.
Severity: blocker → normal

Comment 8

19 years ago
i also get the same problem in windows98, the build is 5 days earilier though.
When i press either stop or get new messages while email is being downloaded the
whole program crashes


Comment 9

19 years ago
sorry for 2 messages, i also get the problem originally in linux
(Assignee)

Comment 10

19 years ago
the mozilla builds now ship with cartman so mozilla can use imap ssl too.
marking this bug as fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
QA-> me
QA Contact: lchiang → huang

Comment 12

18 years ago
Verified SSL is working on Windows 08-25-08-M18 commercial build
Verified SSL is working on Linux 08-25-12-M18 commercial build
Verified SSL is working on Mac 08-25-12-M18 commercial build 
(Except bug 45935 certificate problem on Mac only)
Marking as verified!!
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.