If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Relative links on www.emacs.org are not be resolved correctly

VERIFIED DUPLICATE of bug 22251

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 22251
18 years ago
18 years ago

People

(Reporter: dougt, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you go to the url above, and try to click on Customize, which is a relative
link to Customize.shtml, you will be forwarded to http://customize.shtml.

I am using a build from yesterday night.  When I tried to reproduce this with a
smaller test case, I could not.  Needs more investigation.

Comment 1

18 years ago
The HTML in that page is broken. When I view source it, here's what I see for 
that link:

<A href="http:customize.shtml">

For some reason NC 4.71 resolves that link correctly. Very bizarre.

Why are Netscape employee's not able to set a bug as new? I feel weird 
confirming a Netscape employee's bug report ;-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp

Comment 2

18 years ago
this is a networking bug, resolving http:url without domain name and // wrong
(as jerry baker saw)
Assignee: cbegle → gagan
Component: Browser-General → Networking
QA Contact: asadotzler → tever

Comment 3

18 years ago
This is a dup of bug 22251, which is marked wontfix! I fact the above relative
URLs are a loophole in old RFCs which are deprecated but still in use.

*** This bug has been marked as a duplicate of 22251 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified DUP
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.