Last Comment Bug 307076 - Menus on WYSIWYG editors open on wrong place.
: Menus on WYSIWYG editors open on wrong place.
Status: VERIFIED FIXED
: fixed1.8, regression, testcase
Product: Core
Classification: Components
Component: Layout: R & A Pos (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
: Jet Villegas (:jet)
Mentors:
http://www.dslteam.de/forum/
Depends on:
Blocks: 282754
  Show dependency treegraph
 
Reported: 2005-09-04 21:18 PDT by Pardal Freudenthal (:ShareBird)
Modified: 2009-02-17 09:40 PST (History)
5 users (show)
mtschrep: blocking1.8b4-
asa: blocking1.8b5+
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Picture showing the bug (93.00 KB, image/png)
2005-09-04 21:21 PDT, Pardal Freudenthal (:ShareBird)
no flags Details
not minimal testcase (37.16 KB, application/zip)
2005-09-05 03:53 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
testcase (939 bytes, text/html)
2005-09-05 05:46 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
fix (2.18 KB, patch)
2005-09-30 14:07 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
bzbarsky: review+
bzbarsky: superreview+
mscott: approval1.8b5+
Details | Diff | Splinter Review

Description Pardal Freudenthal (:ShareBird) 2005-09-04 21:18:57 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050904 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050904 Firefox/1.0+

Posting on topics from http://www.dslteam.de/forum/ using the WYSIWYG editor and
trying to edit the font type makes the menu open on a wrong place (only visible
if I scroll the page)

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.dslteam.de/forum/ . You will need an account to be able to
post. You can use Bugmenot for it:
http://bugmenot.com/view.php?url=http%3A%2F%2Fdslteam.de
2. Go to any forum and try to open a new topic clicking on "Neues Thema" button.
3. On the WYSIWYG Editor try to change font type or font size by clicking on the
menu.
4. Apparently it doesn't open.
5. Scroll the page and you will see the menu under the whole editor.

Actual Results:  
The menu opens on the wrong place.

Expected Results:  
Menu opens directly under the scrollbox.
Comment 1 Pardal Freudenthal (:ShareBird) 2005-09-04 21:21:44 PDT
Created attachment 194887 [details]
Picture showing the bug
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-09-05 03:53:35 PDT
Created attachment 194900 [details]
not minimal testcase

I think it is because the containing table cell has position:relative;
Position:relative doesn't work in Mozilla1.7, but seems to work now in current
trunk builds.
When removing that style rule, the menu gets on the right place.
So I think this is a tech evangelism issue.
Comment 3 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-09-05 04:14:46 PDT
Hmm, position:relative is still not working on table cells, so that can't be it
(strange that it makes the difference here, then).
Anyway, I still think this is probably tech evangelism, but a minimal testcase
is needed for that.
Comment 4 Pardal Freudenthal (:ShareBird) 2005-09-05 04:43:25 PDT
As additional information, it works fine with Firefox 1.0.4.
Comment 5 Pardal Freudenthal (:ShareBird) 2005-09-05 05:45:30 PDT
I was able to point a regression date. It works fine with 2005-03-21 build but
stopped to work on 2005-03-22. On 2005-03-22 it's also impossible to put any
text on textbox. This issue was solved on 2005-04-06, but it started the issue
on scrollbox menu.
Comment 6 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-09-05 05:46:01 PDT
Created attachment 194907 [details]
testcase

Ok, this is a minimal testcase.
The behavior for the red bordered popup changed, but it changed in fact for the
better.
The green bordered popup still shows the old, wrong behavior.

So the WYSIWYG editor relies on the fact that td style="position:relative"
doesn't work.

But I think this is not good behavior, both popups should at least act the
same.
Comment 8 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-09-05 14:35:47 PDT
Robert, you might want to take a look at this bug. Maybe it is something that
needs to be fixed for the 1.8 branch.
Comment 9 Asa Dotzler [:asa] 2005-09-13 10:02:26 PDT
->roc
Comment 10 Asa Dotzler [:asa] 2005-09-22 12:15:39 PDT
dbaron, can you look into this regression?
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 13:57:11 PDT
I'm pretty sure this is nsCSSFrameConstructor being inconsistent: it's probably
not pushing an absolute containing block for rel-pos table cells, but it is
probably finding an absolute containing block when we dynamically create the frame.
Comment 12 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 14:07:42 PDT
Created attachment 198046 [details] [diff] [review]
fix

Be more consistent ... no table-related frames push absolute containing blocks
so we shouldn't treat them as abs containing blocks.
Comment 13 Boris Zbarsky [:bz] (still a bit busy) 2005-09-30 14:41:33 PDT
Comment on attachment 198046 [details] [diff] [review]
fix

Looks ok, but we should make sure we fix this as we fix other issues (eg if we
make table caption construction use ConstructBlock).
Comment 14 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 14:44:08 PDT
checked in to trunk.
Comment 15 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 14:44:35 PDT
Comment on attachment 198046 [details] [diff] [review]
fix

need approval for this blocker bug
Comment 16 Scott MacGregor 2005-09-30 15:04:06 PDT
Comment on attachment 198046 [details] [diff] [review]
fix

approving for the branch. Thanks roc.
Comment 17 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 15:24:00 PDT
checked in on branch.
Comment 18 Adam Guthrie 2005-09-30 17:31:22 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050930
Firefox/1.6a1 ID:2005093016

Looks good to me.
Comment 19 Boris Zbarsky [:bz] (still a bit busy) 2009-02-17 09:40:14 PST
Pushed a testcase: http://hg.mozilla.org/mozilla-central/rev/df1c424265ab

Note You need to log in before you can comment on or make changes to this bug.