If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text position shifts on hover with underline text decoration and opacity less than 1

VERIFIED WORKSFORME

Status

()

Core
Layout: Text
--
trivial
VERIFIED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Brett Donald, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050901 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050901 Firefox/1.0+

Text position may shift vertically by one pixel when a :hover style adds an
underline text decoration, and the text is only partially opaque. The shift
occurs the first time the :hover is activated after page load, then the new
(incorrect) position remains until the page is refreshed.

The problem is related to font-size -- if you increase or decrease the font size
(Ctrl+ and Ctrl-), the problem is not apparent at some font sizes, at others the
text may move up one pixel, at others it may move down one pixel. It also may be
related to the presence of other page elements; in this case, a select element
with a top margin.

Reproducible: Sometimes

Steps to Reproduce:
1. Load the test case into Firefox
2. Hover over each of red text strings "THE SPAN CONTENS"

Actual Results:  
Most of the spans move down by one pixel as the underline is added, then remain
one pixel out of alignment from then on, until the page is refreshed. (Depending
on the font size, they may not move, or move up one pixel instead.)


Expected Results:  
Text should not move when adding an underline decoration.
(Reporter)

Comment 1

12 years ago
Created attachment 194983 [details]
Test case
Depends on: 63336
I can see the bug also in Mozilla1.7, so no (recent) regression.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 3

12 years ago
Definitely not recent, has been around for a while... due I believe to twip usage.

We should change severity to normal because I don't think this is a 'trivial'
bug--as more and more people start to use CSS technology, more and more sites
will use the opacity functionality and this bug will be very noticeable.

Comment 4

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072605 Minefield/3.0a7pre

WFM
Yeah, this is worksforme too, with current trunk build.
Brett, could you verify this is worksforme with current trunk build? Thanks.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 6

10 years ago
Agreed -> resolving WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.