Last Comment Bug 307178 - Fastback(bfcache) breaks visited links marking if frame page
: Fastback(bfcache) breaks visited links marking if frame page
Status: RESOLVED FIXED
: fixed1.8, qawanted
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Brian Ryner (not reading)
:
:
Mentors:
http://www.cgl.ucsf.edu/chimera/docs/...
Depends on:
Blocks: blazinglyfastback
  Show dependency treegraph
 
Reported: 2005-09-06 00:59 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28))
Modified: 2008-07-31 02:48 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (666 bytes, patch)
2005-10-31 22:44 PST, Brian Ryner (not reading)
bzbarsky: review+
bzbarsky: superreview+
mtschrep: approval1.8rc2+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2005-09-06 00:59:04 PDT
1. See frame page.
(e.g., http://www.cgl.ucsf.edu/chimera/docs/ProgrammersGuide/Examples/ )
2. Select "Show Only This Frame" in any frame.
3. Back to frame page by back button.
4. Click left frame's link.

The clicked link isn't marked to visited. This problem is only occured with
Fastback(bfcache).
Comment 1 Hideo Oshima 2005-09-06 07:22:08 PDT
I can reproduce on Trunk/Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050906 Firefox/1.6a1
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 16:44:14 PDT
Brian, this is happening because subframe documents don't get OnPageShow
notifications. Is that the expected behaviour? Can you suggest how I can detect
that the subframe document is alive again?
Comment 3 Hideo Oshima 2005-10-05 23:38:15 PDT
Is this depend on bug 274784?
Comment 4 Brian Ryner (not reading) 2005-10-31 21:59:11 PST
(In reply to comment #2)
> Brian, this is happening because subframe documents don't get OnPageShow
> notifications. Is that the expected behaviour? Can you suggest how I can detect
> that the subframe document is alive again?

This is not the expected behavior -- pageshow events should be firing.  It's possible that this is caused by bug 312117, if it's trunk-only.
Comment 5 Brian Ryner (not reading) 2005-10-31 22:31:01 PST
It's not that, this happens on the branch as well.
Comment 6 Brian Ryner (not reading) 2005-10-31 22:44:43 PST
Created attachment 201490 [details] [diff] [review]
patch

We have to clear mEODForCurrentDocument as we start the fake loads for subframes, or they won't notify the content viewer in EndPageLoad, which in turn won't call nsDocument::OnPageShow.
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2005-11-01 10:32:22 PST
Comment on attachment 201490 [details] [diff] [review]
patch

Seems reasonable.  Probably worth getting in on branch too...
Comment 8 Brian Ryner (not reading) 2005-11-01 10:36:07 PST
checked in on trunk.
Comment 9 Brian Ryner (not reading) 2005-11-01 10:38:24 PST
Comment on attachment 201490 [details] [diff] [review]
patch

Requesting rc2 approval.  I think this fix is really safe, and it addresses a noticeable issue for users who use link coloring to figure out where they've been.
Comment 10 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-11-01 12:11:53 PST
It's not just that, right? Is it not also an API issue for Web developers who expect to receive these events?
Comment 11 Brian Ryner (not reading) 2005-11-01 12:15:11 PST
That too.
Comment 12 Mike Schroepfer 2005-11-01 14:25:37 PST
Can we get QA verification on the trunk for this.
Comment 13 Mike Schroepfer 2005-11-02 11:17:29 PST
I'll do the verify today.  
Comment 14 Mike Schroepfer 2005-11-02 18:02:29 PST
Comment on attachment 201490 [details] [diff] [review]
patch

Approved r.e. discussion in bug triage today.
Comment 15 Brian Ryner (not reading) 2005-11-02 18:18:18 PST
Checked in on the branch.

Note You need to log in before you can comment on or make changes to this bug.