Last Comment Bug 307249 - Changing attrs on <input> calls AfterSetAttr too many times
: Changing attrs on <input> calls AfterSetAttr too many times
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Linux
: -- major (vote)
: ---
Assigned To: Allan Beaufour
: Hixie (not reading bugmail)
:
Mentors:
Depends on: 308270
Blocks: 84400
  Show dependency treegraph
 
Reported: 2005-09-06 12:09 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2005-09-28 02:50 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.45 KB, patch)
2005-09-22 05:46 PDT, Allan Beaufour
bzbarsky: review+
bzbarsky: superreview+
bzbarsky: approval1.8b5+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2005-09-06 12:09:29 PDT
It looks like the patch for bug 84400 didn't remove the AfterSetAttr calls in
the SetAttr/UnsetAttr overrides in this class....
Comment 1 Allan Beaufour 2005-09-22 05:46:49 PDT
Created attachment 197030 [details] [diff] [review]
Patch

(In reply to comment #0)
> It looks like the patch for bug 84400 didn't remove the AfterSetAttr calls in

> the SetAttr/UnsetAttr overrides in this class....

I managed to mis-read that a lot of times, dunno why, but now I get it. Here's
a patch that removes the calls to AfterSetAttr() in nsHTMLInputElement.

This should be it for :enabled/:disabled, and we can push it to branch?

(sorry for the delay... jetlag and other bad excuses)
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2005-09-23 12:13:52 PDT
Comment on attachment 197030 [details] [diff] [review]
Patch

r+sr=bzbarsky
Comment 3 Allan Beaufour 2005-09-26 00:58:39 PDT
Checked in on trunk
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2005-09-27 07:42:32 PDT
Comment on attachment 197030 [details] [diff] [review]
Patch

a=bzbarsky for 1.8b5, since bug 84400 already landed there....
Comment 5 Allan Beaufour 2005-09-28 02:50:35 PDT
Checked in on 1.8 branch

Note You need to log in before you can comment on or make changes to this bug.