Errors in .js files not reported correctly

VERIFIED FIXED in M14

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Norris Boyd, Assigned: Norris Boyd)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]w/b minus on 03/07 - fix in hand, URL)

Attachments

(1 attachment)

(Assignee)

Description

19 years ago
Scripts loaded from .js files (rather than directly inline in the HTML page) do 
not have the location of the error reported correctly. The error is reported as 
occurring in the HTML file that loaded the .js file. 

This is a big problem now if we're starting to expect sites to understand and 
respond to errors issued by mozilla.
(Assignee)

Comment 1

19 years ago
Proposing as beta1.
Status: NEW → ASSIGNED
Keywords: beta1
(Assignee)

Comment 2

19 years ago
Created attachment 6171 [details] [diff] [review]
proposed patch
(Assignee)

Comment 3

19 years ago
Added proposed fix attachment.
Whiteboard: fix in hand
(Assignee)

Updated

19 years ago
Target Milestone: M14

Comment 4

19 years ago
Putting on PDT+ radar for beta1.  Will be minus on 03/07.
Whiteboard: fix in hand → [PDT+]w/b minus on 03/07 - fix in hand

Comment 5

19 years ago
This is dup of a very old bug. Now both norris *and* I have gone to the trouble 
to write code to fix this problem. It would be nice if one of the other patch 
actually got checked in.

*** This bug has been marked as a duplicate of 8045 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

19 years ago
Reopening--will fix this bug rather than the dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

19 years ago
Checking in nsHTMLContentSink.cpp;
/m/pub/mozilla/layout/html/document/src/nsHTMLContentSink.cpp,v  <--  nsHTMLCont
entSink.cpp
new revision: 3.317; previous revision: 3.316
done
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
This test page is not reporting an error of any kind now (on any platform.)  
Shouldn't it be giving me a .js error?  Reopening.  (Sorry if this is in error, 
but it's what the report seems to be saying should happen.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

19 years ago
Yes, JavaScript errors no longer pop up dialog boxes.

You can see it by enabling a special preference.... 

Mike, what's the name of the pref?

Comment 10

19 years ago
The pref is called 'javascript.error.alerts'; when set to true, you'll see error
popups.

Currently set to false.  Another for-beta solution to seeing javascript errors
is to start Mozilla with the -console option; on Windows, I think this'll bring
up a new system console, where you can see all the printfs that the browser
generates, including JavaScript errors.

I'm making good progress on a JavaScript console, but it won't be ready for
beta1.


pref("javascript.error.alerts",             true);
(Assignee)

Comment 11

19 years ago
Marking fixed to retry at verification.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 12

19 years ago
verified 2000-03-13-18-M15-nb1b
Status: RESOLVED → VERIFIED
*** Bug 8045 has been marked as a duplicate of this bug. ***
Has this been tested on XML documents?  There was some discussion of that in bug
8045.
You need to log in before you can comment on or make changes to this bug.