Closed Bug 307405 Opened 16 years ago Closed 14 years ago

Blocks with overflow:auto are not rendered correctly if positioned more than 32768px from the document edge

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: ecfbugzilla, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(2 files)

This problem is very frequent in long threads on the forum xpoint.ru - code
blocks are not displayed at all or only partially or grey boxes appear.
Investigation brought up that this happens to all blocks with overflow:auto if
their position is more than 32378 pixel from the upper edge of the document.
Minimal testcase follows.

The problem is likely to be related to bug 269002 and bug 215055, I can't say it
for sure though.

Tested with Firefox 2005090708 trunk build, Firefox 2005090707 branch build,
Mozilla 1.7.10, Firefox 1.0, DeerPark Alpha 2 - all positive.
Here the position of both blocks is 32000 pixel from the top edge of the
document. You should scroll down to the end of the document using the End
button and see the green block immediately following the red block - no bug.
This is exactly the same testcase but the blocks are positioned 33000 pixel
from the top edge of the document. If you scroll down using the End button you
will see the red block (the one with overflow:auto) twice. Scrolling up and
down with the arrow keys will show more strange effects: red block at the
correct position disappearing, red block at the wrong position being replaced
by a gray box and so on. Note that in Firefox moving the mouse to any scrollbar
button (not even clicking it) makes the page display correctly. Same thing
happens when reloading while at the end of the document. However, if you reload
while being at the top of the document - you will get the wrong behavior back.
Couldn't reproduce the problem on Linux with Mozilla 1.7.8 and Firefox 1.0.6,
maybe this is limited to Windows.

One thing that probably isn't clear: the bug has nothing to do with relative
positioning. It doesn't matter how you position your element - by using
position:relative or by putting a huge amount of text before it. It is only
important that we have more than 32768 pixel between the block and the top edge
of the document. I only used relative positioning to keep the testcase small.
Probably bug 255706 is also the same bug.
This is a duplicate -- the problem is the 16-bit widget coordinates involved.
Depends on: 255706
Whiteboard: DUPEME
Firefox 2 still shows this behavior - build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

The behavior on trunk has changed but it is still incorrect. The red block is now only shown once but at the wrong position. Tested in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061130 Minefield/3.0a1
(In reply to comment #5)
> This is a duplicate -- the problem is the 16-bit widget coordinates involved.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.