browser.xul.error_pages.enabled causes data loss by losing data on current page

RESOLVED DUPLICATE of bug 157004

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 157004
12 years ago
12 years ago

People

(Reporter: Lupin.wp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050822 Firefox/1.0.6 (Debian package 1.0.6-3)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050822 Firefox/1.0.6 (Debian package 1.0.6-3)

If browser.xul.error_pages.enabled is true, then the error pages replace the
current page in the back/forwards history rather than adding to it. This leads
to data loss if the current page has unsaved form data.

Reproducible: Always

Steps to Reproduce:
0. Check that browser.xul.error_pages.enabled is true in about:config
1. Open a new tab and go to google.com or some other page with a form
2. Type something novel in the search box
3. Enter an invalid url in the location bar and hit enter

Actual Results:  
The "page load error" page appears as expected, but the back button remains
disabled. There seems to be no way to return to google and recover the form data.

Expected Results:  
Treated the page load error as a normal page and added it to the history rather
than obliterating the current page and all associated data, so that the form
data could be recovered by stepping through the history.
Mozilla/5.0 (Windows; U; Win98; es-ES; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Same problem here.

*** This bug has been marked as a duplicate of 157004 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.