Last Comment Bug 307734 - Some plugins result in truncated accessible page content
: Some plugins result in truncated accessible page content
Status: RESOLVED FIXED
: access, fixed1.8, sec508
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows XP
-- critical (vote)
: ---
Assigned To: Aaron Leventhal
:
: alexander :surkov
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 10:13 PDT by Aaron Leventhal
Modified: 2005-09-22 12:37 PDT (History)
0 users
asa: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
1) Have an object to own the native plugin placeholder accessible, which knows its place in the Gecko tree, 2) Only use first child window for plugin if it exists (6.15 KB, patch)
2005-09-09 10:14 PDT, Aaron Leventhal
parente: review+
jst: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description User image Aaron Leventhal 2005-09-09 10:13:45 PDT
Two problems with how we expose plugins:
1) Windowless plugins with MSAA content are not exposed
2) Gecko content after the plugin is getting cut off, because the plugin doesn't
point back into Gecko content for IAccessible::get_accNextSibling()
Comment 1 User image Aaron Leventhal 2005-09-09 10:14:54 PDT
Created attachment 195430 [details] [diff] [review]
1) Have an object to own the native plugin placeholder accessible, which knows its place in the Gecko tree, 2) Only use first child window for plugin if it exists
Comment 2 User image Johnny Stenback (:jst, jst@mozilla.com) 2005-09-21 14:35:04 PDT
Comment on attachment 195430 [details] [diff] [review]
1) Have an object to own the native plugin placeholder accessible, which knows its place in the Gecko tree, 2) Only use first child window for plugin if it exists

-In nsHTMLWin32ObjectOwnerAccessible::GetChildCount():

+  nsCOMPtr<nsIAccessible> onlyChild;
+  GetFirstChild(getter_AddRefs(onlyChild));
+  *aChildCount = (onlyChild != nsnull);

This does the right thing, but it's a bit odd to assign a boolean value into a
count (int) variable. Maybe change that to *aChildCount = (onlyChild == nsnull)
? 0 : 1; to make what's going on here a bit more explicit?

sr=jst

Note You need to log in before you can comment on or make changes to this bug.