Closed Bug 307802 Opened 15 years ago Closed 15 years ago

URL treated as bad if it contains 1 "\" instead of "/"

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: jimy.joshi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

URL treated as bad if it contains 1 "\" instead of "/".
If the URL contains all wrong kind slashes i.e. the "\", it converts it into all
"/" which is good but if we have only one or two wrong slashes in the url, the
page is not loaded and gives an error. 

Reproducible: Always

Steps to Reproduce:
1.type in long url containing more than one sub levels afters the domain name
2.change any of the slashes in the url to "\"
3.See i told you

Actual Results:  
Object not found !!!! Error

Expected Results:  
before fetching the url it needs to check if all the slashes used as a part of
the url are good or not, if not change it accordingly.

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.