Increase the default size of the download window so that all buttons are visible

RESOLVED FIXED in Camino1.0

Status

--
enhancement
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: nick.kreeger, Assigned: nick.kreeger)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
macOS
fixed1.8
Bug Flags:
camino1.0 +

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

14 years ago
Currently, the default size of the download window doesn't show all the buttons
in the download window toolbar, increase the default/minimum size of the
download window to fix this.

Comment 1

14 years ago
Nick I would disagree with this. What I think should be done is the following.

The default set should be:
Pause/Resume - Cancel/Retry - space - Open - Show - space - Clean Up

This set fit's nicely on the current bar and shows all the essential options to
the user. If the user sets the toolbar not to use text they can even put another
2 items without having to scroll. Note that I think it's more then ok to leave
some of the items in the customization sheet.
*** Bug 310942 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

14 years ago
Whats the status of this bug, Mike do we still want to do this, or change the
default toolbar set?

Comment 4

14 years ago
The layout proposed makes it very easy to cancel a download when the user really
wants to Pause it instead. My suggestion is to move these dangerous operations
to the contextual menu.

Also, the cancel function is pointless. The user will either follow it with
restart or delete. So why not just make restart and delete available and remove
the cancel function?

Lastly, the user should be allowed to delete a downloading/downloaded item by
dragging the item to the trash can.
(In reply to comment #4)
> Also, the cancel function is pointless. The user will either follow it with
> restart or delete. So why not just make restart and delete available and remove
> the cancel function?

How do you cancel a download with no "Cancel" button? Say we use "Delete", what
happens when a user accidentally deletes a download he/she really wanted? How
does the user bring it back? And if he/she has navigated away from the page they
were on, they can no longer find the link to the download he/she wanted.

As it stands now (or will stand at least), a users can cancel a download and
restart it at any point. If they delete it, there's really no way to restart it.
It'd be good to have the standard set/size ironed out for 1.0.

Mike, can you give some input on this bug?
Flags: camino1.0?
Target Milestone: --- → Camino1.0
should be easy.
Flags: camino1.0? → camino1.0+
(Assignee)

Comment 9

14 years ago
This is the updated NIB, sets the default panel size to 300 as well as content inside the panel
(In reply to comment #8)
> Created an attachment (id=201570) [edit]
> Changes the default name of the ProgressView to ProgressView1 so update will be
> seen without user trashing pref plist

Do we really care about that? I'd think we'd only care about new users as those downloading nightlies probably know about new features. Users switching from 0.8 to 1.0 will already notice the difference because the name of the plist changed.

Either way, just thought I'd add a comment.
(Assignee)

Comment 11

14 years ago
We did the same thing when we changed the toolbar, i don't think every user has resized their download window.
(Assignee)

Comment 12

14 years ago
Notice that if we want to keep the pref (and only worry about new installs of the app) then don't use the patch. All the patch is for is to ensure that Camino uses a diffrent setting for the Download window so the default size will be what's in the new NIB file.

Comment 13

14 years ago
Comment on attachment 201571 [details]
New ProgressView.nib, now the default width is 300 px, so all the default buttons fit on the default width

Don't you want ProgressDialog.nib?
Attachment #201571 - Flags: review-
(Assignee)

Comment 14

14 years ago
Posted file Oops, this is ProgressDialog.nib (obsolete) —
Attachment #201571 - Attachment is obsolete: true

Updated

14 years ago
Attachment #201638 - Flags: review+

Comment 15

14 years ago
Comment on attachment 201570 [details] [diff] [review]
Changes the default name of the ProgressView to ProgressView1 so update will be seen without user trashing pref plist

Not gonna do this, but we can change your e-mail address if you want.
Attachment #201570 - Attachment is obsolete: true
(Assignee)

Comment 16

14 years ago
After further testing of the modified NIB, the old attatchment had a problem with the size in CHStackView. This is now correct
Attachment #201638 - Attachment is obsolete: true

Comment 17

14 years ago
Comment on attachment 201650 [details]
correct size for CHStackView

In the previous nib, the CHStackView was the width of the download manager window (300px), which put it beneath the window's scrollbar.
Attachment #201650 - Flags: review+
landed trunk and branch
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.