[FIX]Iframes are not drawn after being shown

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
Layout: HTML Frames
P2
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Erik Arvidsson, Assigned: bz)

Tracking

({fixed1.8.1, testcase})

Trunk
mozilla1.9alpha1
fixed1.8.1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
If a div with display none contains an iframe and then the display of the div is
changed to block (or "") the content of the iframe is not shown (the borders of
the iframe are shown).

I think this one worked in the Aviary branch but it does not work in the 1.8
branch or on the trunk. I'll try to verify that it really worked in 1.7.

Test case comming...
(Reporter)

Comment 1

12 years ago
Created attachment 195762 [details]
HIdes div during page load and shows it onload

Comment 2

12 years ago
This is also broken with Firefox 1.0.x
Keywords: testcase
Created attachment 209311 [details] [diff] [review]
Patch to fix

This has been broken since about forever, actually...

The problem is that we destroy the frame but don't null out the parentWidget on the docshell.  Then when the document starts to load we create a presentation (see DocumentViewerImpl::InitInternal), even though the iframe is display:none by then.

The patch just makes sure we unset the parentWidget when the nsSubDocumentFrame dies; the rest is cleanup that I thought made the code clearer.
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #209311 - Flags: superreview?(jst)
Attachment #209311 - Flags: review?(cbiesinger)
The other question is whether this is worth fixing on the 1.8.1 branch.  I think it may be...
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Summary: Iframes are not drawn after being shown → [FIX]Iframes are not drawn after being shown
Target Milestone: --- → mozilla1.9alpha
Attachment #209311 - Flags: review?(cbiesinger) → review+
Comment on attachment 209311 [details] [diff] [review]
Patch to fix

sr=jst
Attachment #209311 - Flags: superreview?(jst) → superreview+
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Comment on attachment 209311 [details] [diff] [review]
Patch to fix

I think it's worth it to take this on the 1.8 branch.  This makes sure to not have a dangling widget pointer on the docshell, basically.
Attachment #209311 - Flags: approval1.8.1?
Flags: blocking1.8.1?

Updated

12 years ago
Attachment #209311 - Flags: approval1.8.1? → branch-1.8.1?(jst)

Updated

12 years ago
Attachment #209311 - Flags: branch-1.8.1?(jst) → branch-1.8.1+
Fixed on branch.
Keywords: fixed1.8.1
Flags: blocking1.8.1?
You need to log in before you can comment on or make changes to this bug.