Pop-up blocking alert should give more feedback when pop-up is blocked

VERIFIED FIXED

Status

--
enhancement
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Dave, Assigned: mikepinkerton)

Tracking

({fixed1.8.1})

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050819 Camino/0.9a2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050819 Camino/0.9a2+

There should be two lists for pop-ups: blocked sites and allowed sites, and
there should be a choice list
  Pop-ups from unknown sites: allow
                              deny
                              ask
If ask, a dialog offers Add to Allow list, Add to Deny list, Allow this time,
Deny this time.

Reproducible: Always
Do we really need this?  It seems easy enough to unblock legit sites (or
whitelist them manually), and most of the time most people want popups blocked.

Comment 2

13 years ago
i agree. i for one would find this annoying rather than helpful. however, some
kind of unobtrusive notification that a popup was blocked (like the image
firefox displays) would be helpful so that when you go to a site and it doesn't
work, you don't just stare at it going "why doesn't it work?!"
> however, some kind of unobtrusive notification that a popup was blocked

On the left edge of the status bar there's a "blocked popup" notification--which
also allows you to unblock the popup (see the 4th header on
http://www.caminobrowser.org/features.html)
Simon, something we need? Or is this a WONFIX?

Comment 5

13 years ago
I think we just need to give a little more feedback that a popup was blocked (play a sound, throb the blocked indicator). I think a dialog would be almost as annoying as the popup.

Comment 6

13 years ago
Yes, but we should also give the user a say in that as well because those throbber bursts and sounds can become annoying and distracting after a while.
(Reporter)

Comment 7

13 years ago
No buzzers and flashing lights please.  Just create the pop-up window and initially display a question with response buttons in it.  Clicking a button will either cause the window to close or cause the window content to contain the intended HTML content.
Confirming as a RFE. Updating summary to reflect latest comments...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Pop-up blocking should have an "ask me" mode → Pop-up blocking alert should give more feedback when pop-up is blocked
(Assignee)

Comment 9

13 years ago
i sorta like a gentle throbbing of the icon, which wouldn't be like a flashing ad blinking 20 times/sec.

i agree we need to find a way to make it more visible, but more dialogs most certainly isn't the answer.
I think pink fixed this yesterday, too.  Can't ignore that feedback.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> I think pink fixed this yesterday, too.

Fixed what?  The nightly build has nothing in the Preferences for pop-ups.
(In reply to comment #11)
> Fixed what?  The nightly build has nothing in the Preferences for pop-ups.

Trunk nightlies and nightlies off the 1.8 branch (as opposed to the 1.8.0 branch) will show a new notification... much bigger. You won't see anything new in the prefs though.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.