Closed Bug 308255 Opened 14 years ago Closed 14 years ago

Downloads Lose Date/Time Stamp

Categories

(Toolkit :: Downloads API, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178506

People

(Reporter: shuntsbe, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When downloading files in Firefox (1.0.6) for Mac OS X, the downloaded files
have their modification date set to the current date. Other browsers such as
MSIE use the modification date of the resource as per the http header. Please fix.

Reproducible: Always

Steps to Reproduce:
1. Download a file
2. Get info on file
3. Date is current date


Actual Results:  
File modification date is set to the current date.

Expected Results:  
Date should be set to date the file was modified on the server.
There doesn't seem to be consensus on this, but in any case, there's an open bug
about it.

*** This bug has been marked as a duplicate of 178506 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.