If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bad javascript can lockup Mozilla

VERIFIED DUPLICATE of bug 13350

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED DUPLICATE of bug 13350
18 years ago
10 years ago

People

(Reporter: locka, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Save the HTML below into a file and view it with Mozilla. Mozilla goes into an 
infinite loop which it never exits. CPU activity goes through the roof and the 
UI is unresponsive and must be killed.

<html>
<head>
<title>Death by Javascript!</title>
</head>
<body>
<p>
<script language="JavaScript">
document.write("Script running");
while(1 > 0) ;
document.write("Script complete");
</script>
</p>
</body>
</html>
(Reporter)

Updated

18 years ago
Summary: Bad javascript can kill Mozilla → Bad javascript can lockup Mozilla

Comment 1

18 years ago
This is similar to bug 13350 except that there's no issue with GC here, it's 
just that the browser locks up due to the infinite loop. Nav 4.7 keeps the UI 
alive at least.
Assignee: rogerl → vidur
Component: Javascript Engine → DOM Level 0
QA Contact: rginda → desale
Marking as dup of bug 13350.

*** This bug has been marked as a duplicate of 13350 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified Dup.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Depends on: 30942

Updated

16 years ago
No longer depends on: 30942
You need to log in before you can comment on or make changes to this bug.