Last Comment Bug 308455 - Move labels
: Move labels
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: XForms (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Peter Nunn
: Stephen Pride
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-14 03:35 PDT by Peter Nunn
Modified: 2005-10-10 20:47 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix to move labels before content and all other xforms after (2.49 KB, patch)
2005-09-14 03:36 PDT, Peter Nunn
bugs: review+
Details | Diff | Review
Patch to move labels before content (2.50 KB, patch)
2005-09-14 13:06 PDT, Peter Nunn
bugs: review+
doronr: review+
Details | Diff | Review
Move label for output too (1.19 KB, patch)
2005-09-26 06:07 PDT, Allan Beaufour
bugs: review+
doronr: review+
Details | Diff | Review

Description Peter Nunn 2005-09-14 03:35:10 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050914 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050914 Firefox/1.6a1

Most xforms processors have labels before the content and the alerts/help/hint
after the content.
The default behavior is to place all decorations before the content of the control.

Reproducible: Always
Comment 1 Peter Nunn 2005-09-14 03:36:25 PDT
Created attachment 196026 [details] [diff] [review]
Fix to move labels before content and all other xforms after

Patch moves controls to after the xforms content but leaves labels before the
content
Comment 2 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2005-09-14 06:10:56 PDT
(In reply to comment #1)
> Created an attachment (id=196026) [edit]
> Fix to move labels before content and all other xforms after
> 
> Patch moves controls to after the xforms content but leaves labels before the
> content

Please, don't use tabs, but spaces. And I didn't check whether you're using
\r\n line endings. It must be \n.


Comment 3 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2005-09-14 09:41:04 PDT
Comment on attachment 196026 [details] [diff] [review]
Fix to move labels before content and all other xforms after

Ok, there were no \r\ns.
But please replace tabs with spaces. r+
Comment 4 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2005-09-14 09:58:24 PDT
Comment on attachment 196026 [details] [diff] [review]
Fix to move labels before content and all other xforms after


>   <!-- LABEL: <DEFAULT> -->
>   <binding id="xformswidget-label"
>            extends="chrome://xforms/content/xforms.xml#xformswidget-base">
>     <content>
>       <html:span anonid="content"></html:span>
>       <html:span anonid="anoncontent">
>-      <children/>
>+				<children/>
>       </html:span>


And what is this change? Remove it.

>     <content>
>-      <children/>
>+			<children includes="label" />

Remove the space before \>

>                   onkeypress="if (event.keyCode == event.DOM_VK_RETURN) this.parentNode.dispatchDOMActivate();"
>                   xbl:inherits="accesskey"/>
>+      <children />

Remove the space before \>


>   <binding id="xformswidget-textarea"
>            extends="chrome://xforms/content/xforms.xml#xformswidget-base">
>     <content>
>-      <children/>
>+			<children includes="label" />

Remove the space before \>
Comment 5 Peter Nunn 2005-09-14 13:06:21 PDT
Created attachment 196071 [details] [diff] [review]
Patch to move labels before content
Comment 6 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2005-09-15 11:55:02 PDT
Comment on attachment 196071 [details] [diff] [review]
Patch to move labels before content

Aaron, what do you think about this?
Comment 7 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2005-09-15 11:58:35 PDT
Comment on attachment 196071 [details] [diff] [review]
Patch to move labels before content

or doron?
Comment 8 Allan Beaufour 2005-09-16 04:00:43 PDT
Checked in to trunk
Comment 9 alexander :surkov 2005-09-25 22:45:17 PDT
Should 'output' element have the same behaviour?
Comment 10 Allan Beaufour 2005-09-26 01:08:30 PDT
(In reply to comment #9)
> Should 'output' element have the same behaviour?

Hmmm, yes I guess it should. I do not know whether we just missed it, or
somebody had a reason for not including it? (I just forgot about it)
Comment 11 Allan Beaufour 2005-09-26 06:07:51 PDT
Created attachment 197412 [details] [diff] [review]
Move label for output too
Comment 12 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2005-09-26 10:55:06 PDT
Comment on attachment 197412 [details] [diff] [review]
Move label for output too

oops, I don't know how I managed to set the sr flag
Comment 13 alexander :surkov 2005-09-26 20:10:37 PDT
It seems to me label for checkbox is right behind label. Should <xf:input
type="xsd:boolean" have the same behaviour or not?
Comment 14 Allan Beaufour 2005-09-27 06:22:51 PDT
(In reply to comment #11)
> Created an attachment (id=197412) [edit]
> Move label for output too

Checked in to trunk
Comment 15 Allan Beaufour 2005-09-27 06:24:53 PDT
(In reply to comment #13)
> It seems to me label for checkbox is right behind label. Should <xf:input
> type="xsd:boolean" have the same behaviour or not?

I'm no big UI wiz. I just assume that XForms labels appear before the control.
So I do not know...
Comment 16 aaronr 2005-09-27 10:27:08 PDT
(In reply to comment #15)
> (In reply to comment #13)
> > It seems to me label for checkbox is right behind label. Should <xf:input
> > type="xsd:boolean" have the same behaviour or not?
> 
> I'm no big UI wiz. I just assume that XForms labels appear before the control.
> So I do not know...

Looks like we are being consistent with the other processors, too.  An
individual boolean input will have the label before the checkbox, just like the
label is before a regular input.  However, if you have a select with
appearance='full', then the labels will be after the checkboxes in the group.
Comment 17 alexander :surkov 2005-09-27 21:35:38 PDT
(In reply to comment #16)
> (In reply to comment #15)
> > (In reply to comment #13)
> > > It seems to me label for checkbox is right behind label. Should <xf:input
> > > type="xsd:boolean" have the same behaviour or not?
> > 
> > I'm no big UI wiz. I just assume that XForms labels appear before the control.
> > So I do not know...
> 
> Looks like we are being consistent with the other processors, too.  An
> individual boolean input will have the label before the checkbox, just like the
> label is before a regular input.  However, if you have a select with
> appearance='full', then the labels will be after the checkboxes in the group.

Ok. It's just a question. I looked at xul:checkbox and I thought it would be good.

(In reply to comment #14)
> (In reply to comment #11)
> > Created an attachment (id=197412) [edit] [edit]
> > Move label for output too
> 
> Checked in to trunk

I have a question. Since patches were checked when bug will be fixed and when
patched will be included into trunk? From what does it depended on?
Comment 18 Allan Beaufour 2005-09-28 04:48:01 PDT
> (In reply to comment #14)
> > (In reply to comment #11)
> > > Created an attachment (id=197412) [edit] [edit] [edit]
> > > Move label for output too
> > 
> > Checked in to trunk
> 
> I have a question. Since patches were checked when bug will be fixed and when
> patched will be included into trunk? From what does it depended on?

To "branch" I guess you mean. We do not have a good procedure for that for
now... we'll probably update branch in batches, or maybe we could just build an
XPI for branch manually occasionally.
Comment 19 aaronr 2005-10-06 17:32:18 PDT
checked into branch 20051004

Note You need to log in before you can comment on or make changes to this bug.