XUL Javascript error when focusing entryfield than button

RESOLVED DUPLICATE of bug 236791

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 236791
13 years ago
13 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
This is a strange one.

When doing a certain order of focus events in a form, you get a Javascript error
about XUL on the console.

Testcase attached.
(Reporter)

Comment 1

13 years ago
Created attachment 196047 [details]
Testcase

Load testcase and notice the console.

You might have to shift reload to see it.

Error is:

Error: [Exception... "'Permission denied to get property
XULElement.selectedIndex' when calling method:
[nsIAutoCompletePopup::selectedIndex]"	nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
http://www.kaply.com/work/xulerr.html :: <TOP_LEVEL> :: line 6"  data: no]
Source File: http://www.kaply.com/work/xulerr.html
Line: 6
(Reporter)

Comment 2

13 years ago
make that Ctrl+Shift+Reload.
bug 236791, no?
(Reporter)

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 236791 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.