Closed Bug 308689 Opened 15 years ago Closed 15 years ago

xf:select doesn't inintialize via bound node

Categories

(Core Graveyard :: XForms, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: spsh, Assigned: doronr)

Details

(Keywords: fixed1.8)

Attachments

(2 files)

816 bytes, application/xhtml+xml
Details
9.35 KB, patch
smaug
: review+
aaronr
: review+
Details | Diff | Splinter Review
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

when xforms are rendered xf:select doesn't load initial state from bound node

Reproducible: Always

Steps to Reproduce:
1. open testcase

Actual Results:  
Four checkboxes are unchecked

Expected Results:  
First two checkboxes must be checked and last two must be unchecked
Attached file testcase
valid testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch patchSplinter Review
I forgot to add the preselection to choice and itemset.  This fixes that.
Assignee: aaronr → doronr
Status: NEW → ASSIGNED
Attachment #196681 - Flags: review?(smaug)
Attachment #196681 - Flags: review?(smaug)
Attachment #196681 - Flags: review?(aaronr)
Attachment #196681 - Flags: review+
Attachment #196681 - Flags: review?(aaronr) → review+
checked into trunk/branch
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.