Last Comment Bug 308689 - xf:select doesn't inintialize via bound node
: xf:select doesn't inintialize via bound node
Status: RESOLVED FIXED
: fixed1.8
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Doron Rosenberg (IBM)
: Stephen Pride
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 09:25 PDT by Splash
Modified: 2016-07-15 14:46 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (816 bytes, application/xhtml+xml)
2005-09-15 09:26 PDT, Splash
no flags Details
patch (9.35 KB, patch)
2005-09-19 12:04 PDT, Doron Rosenberg (IBM)
bugs: review+
aaronr: review+
Details | Diff | Splinter Review

Description Splash 2005-09-15 09:25:12 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

when xforms are rendered xf:select doesn't load initial state from bound node

Reproducible: Always

Steps to Reproduce:
1. open testcase

Actual Results:  
Four checkboxes are unchecked

Expected Results:  
First two checkboxes must be checked and last two must be unchecked
Comment 1 Splash 2005-09-15 09:26:11 PDT
Created attachment 196195 [details]
testcase
Comment 2 aaronr 2005-09-19 10:11:39 PDT
valid testcase
Comment 3 Doron Rosenberg (IBM) 2005-09-19 12:04:08 PDT
Created attachment 196681 [details] [diff] [review]
patch

I forgot to add the preselection to choice and itemset.  This fixes that.
Comment 4 Doron Rosenberg (IBM) 2005-09-27 08:14:37 PDT
checked into trunk/branch

Note You need to log in before you can comment on or make changes to this bug.