The default bug view has changed. See this FAQ.

Caret is invisible when entering an empty designmode field.

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
Editor
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: Egon Knapen, Assigned: peterv)

Tracking

Trunk
mozilla1.9.2a1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: midas, URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When an designmode field is still empty when you enter by clicking the mouse in
it, you don't see a cursor. The cursor will appear only after you start typing
characters.

Reproducible: Always

Steps to Reproduce:
1. visit the site,
2. click 'view source'
3. delete everything
4. unclick 'view source' (remove check)
5. click with mouse in textfield

Actual Results:  
You don't see a focus or an blinking cursor. Or any cursor what so ever...

Expected Results:  
In a normal textfield or textarea, when you it gets the focus, you see a
blinking cursor.

Problem happens under Windows XP, but also under MacOSX (Tiger), with using
Firefox 1.5 beta 1 or Camino 1.0a1.

Comment 1

12 years ago
WFM, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908
Firefox/1.4 ID:2005090806 However, the cursor is very very small, making it hard
to see, still a bug, but not the same as decribed.
(Reporter)

Comment 2

12 years ago
No it's not visible. That other one is when there is text, and you move the
cursor totally to the beginning, then I see a very small cursor.

Both are bugs I think that should be finished!

Comment 3

12 years ago
See this as well with 20050916 branch build
Assignee: nobody → mozeditor
Component: General → Editor
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.0 Branch

Updated

12 years ago
Whiteboard: midas

Comment 4

12 years ago
Reproducible (no cursor) with SeaMonkey/20050904/1.1a, I see a very small cursor
with SeaMonkey/20050907/1.1a.

Comment 5

12 years ago
Oops, now I also see the very small cursor with SeaMonkey/20050904/1.1a so my
comment 4 is incorrect, sorry.
(Reporter)

Comment 6

12 years ago
The DesignMode has been a big improvement in the 1.5beta2 over the 1.0.6 version
of firefox, but this small or invisible cursor is really something that should
get quickly fixed, to make it a perfect designmode....

Updated

12 years ago
Keywords: testcase
Version: 1.0 Branch → 1.8 Branch
Keywords: helpwanted

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: cursor is invisible when enter an empty designmode field. → Caret is invisible when entering an empty designmode field.

Comment 7

11 years ago
Same on trunk/win xp --> trunk
Flags: blocking1.9a1?
Version: 1.8 Branch → Trunk

Updated

11 years ago
Flags: blocking1.9a1? → blocking1.9-
QA Contact: editor
Assignee: mozeditor → nobody

Comment 8

10 years ago
The cursor is also invisible when a text-area or design mode is used above a transparent layer (see bug 343240).

Afaik it was fixed in 1.5 but is still not fixed in 2.0.
When will this be fixed? (please?)
This now works for me [Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102510 Minefield/3.0a9pre].
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

10 years ago
Under latest night build 3.0a9pre (1.Nov) it is visible. But it's very small...

Same when in there is text, and you go to the last line, it sometimes is small too. Still same behaviour as in 2.0.0.8.
Resolution: WORKSFORME → INCOMPLETE
Reopening per comment 10.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Oh I see, the problem is that when you delete everything in view source mode, there's *nothing* left in the iframe. When we draw the caret in an empty iframe, the caret is offset vertically, that's why we always add a <br> tag to an empty iframe.

We need to either:
1. Fix the caret drawing/positioning code when it's drawn in an *empty* iframe document.
2. Add a <br> to the iframe when all its content is deleted.

Taking bug.
Status: REOPENED → ASSIGNED

Updated

10 years ago
Assignee: nobody → chris
Status: ASSIGNED → NEW
Blocks: 237964

Updated

9 years ago
Blocks: 424615

Updated

8 years ago
Blocks: 395965
(Assignee)

Comment 13

8 years ago
Created attachment 381760 [details]
Testcase
Assignee: chris → peterv
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 395965
(Assignee)

Comment 15

8 years ago
Created attachment 381763 [details] [diff] [review]
v1
Attachment #381763 - Flags: superreview?(roc)
Attachment #381763 - Flags: review?(roc)
(Assignee)

Updated

8 years ago
Keywords: helpwanted, testcase
Target Milestone: --- → mozilla1.9.2
Attachment #381763 - Flags: superreview?(roc)
Attachment #381763 - Flags: superreview+
Attachment #381763 - Flags: review?(roc)
Attachment #381763 - Flags: review+
(Assignee)

Comment 16

8 years ago
http://hg.mozilla.org/mozilla-central/rev/94a7af7250dd
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago8 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: mozilla1.9.2 → mozilla1.9.2a1

Updated

8 years ago
Depends on: 503531

Comment 17

8 years ago
This caused bug 503531
Depends on: 561584
You need to log in before you can comment on or make changes to this bug.