RegExp behaves differently if JSOPTION_STRICT is active

RESOLVED DUPLICATE of bug 308566

Status

()

RESOLVED DUPLICATE of bug 308566
13 years ago
13 years ago

People

(Reporter: daumling, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When turning on JSOPTION_STRICT, some regular expressions show differnet
behavior after issuing a warning than if the option is turned off.

Reproducible: Always

Steps to Reproduce:
1. In Shell, enter this line: 'abcdef'.match(/\143\144/)
2.
3.

Actual Results:  
null

Expected Results:  
cd

This bug is similar to bug 306727. Line 1093 (num = 0x10000( should be replaced
with:
                state->cp = termStart;
                goto doOctal;
(Reporter)

Updated

13 years ago
Version: Trunk → 1.8 Branch
mrbkap fixed this as part of the fixes for bug 306727 and bug 308566.

/be

*** This bug has been marked as a duplicate of 306727 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
The patch for 306727 does not fix this bug; the bug is similar, but not a duplicate.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Sorry, you are right.  I was trying not to dup against a restricted bug. 
mrbkap, can we unrestrict?

/be

*** This bug has been marked as a duplicate of 308566 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.