Cells pasted from excel to mail do not paste into mail composer in seamonkey

RESOLVED DUPLICATE of bug 228920

Status

--
major
RESOLVED DUPLICATE of bug 228920
13 years ago
12 years ago

People

(Reporter: uberkiwi, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Bug Flags:
blocking-seamonkey1.0.1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050817 SeaMonkey/1.0a Mnenhy/0.7.2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050817 SeaMonkey/1.0a

In Mozilla 1.7.10, one can paste cells from Excel into Mail and they will be
converted into an HTML table.

In seamonkey, it appears that this is broken, and nothing appears to paste,
unless you choose to paste without formatting, in which case it pastes the plain
text from the cells.

Reproducible: Always

Steps to Reproduce:
1.COpy cells from excel spreadsheet
2.Paste into mail composer
3.

Actual Results:  
Nothing appears to paste.

Expected Results:  
An HTML Table version of the excel cells.

Comment 1

13 years ago
Which version of Excel?

xref bug 228920 (not that I think it's the same problem).
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Which version of Excel?
Excel 2003
> 
> xref bug 228920 (not that I think it's the same problem).
Actually, it is similar. I tested sending the "invisible" data, and it does
appear in the sent email, however it is unformatted (not in an HTML table).

(Reporter)

Comment 3

13 years ago
Same behaviour when pasting from OpenOffice 2.0beta "calc".

Pasting into Mozilla 1.7.12 email composer works a treat.

Comment 4

13 years ago
(In reply to comment #2)
> > xref bug 228920 (not that I think it's the same problem).
> Actually, it is similar. I tested sending the "invisible" data, and it does
> appear in the sent email, however it is unformatted (not in an HTML table).

Was that because the mail was sent as plain text, or was the information 
unformatted within an HTML message?

Do you also see the symptom reported there on saving as draft, reopening, and 
seeing the table in place?  You can check whether the extra, empty <col> 
described at that bug is in your example by:
 1) Opening an HTML compose window
 2) Pasting your table data
 3) Select | All, followed by  Insert | HTML

I don't have an Excel of sufficiently modern vintage to output in HTML.  I do 
have Word 2000, and I see a similar issue when pasting a Word table (or one or 
several cells): on paste, the table is invisible; reopening a saved draft lets 
me see it.  I don't see this extra <col> tag, however.

I've also looked directly at the clipboard data (using CLIPBRD.EXE under Win2K). 
In the Word 2000 case, the pasted cells (for the entire table or a subset) are 
stored in an HTML <table> element, and that <table> is the paste fragment.
(xref bug 228920 comment 6)


The HTML that I see in the compose-window buffer is badly distorted from the 
text that Word actually puts in place, with large sections moved out of sequence 
and other problems; part of the issue is probably due the relative lameness of 
HTML compose in mail, which only allows editing the contents of <body> but 
copies in all the <head> tags to the buffer anyway.
Keywords: regression
Version: unspecified → Trunk
reproduced with 
Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060228 SeaMonkey/1.5a and MS Excel 2000
Compose message is in HTML

create a new message
copy a few cells with text and numbers, some bold text
paste into the new message
nothing is displayed at all

save the message as draft, close the compose message window
open the draft message : the content of the excel table is there, but only the plain text content (no formatting, no table actually)

pasting without formatting also works without going through the 'save as draft' step.

rich text copy paste is broken ??
reproduced with Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060307 SeaMonkey/1.5a

when sending the message and looking at the source received, here it is (an excel table, but no content : no row, no col, no data):


From - Wed Mar 08 13:04:09 2006
X-Account-Key: account1
X-UIDL: 1141819276.30103.mrelay5-1
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <olivier.vit@free.fr>
Delivered-To: online.fr-olivier.vit@free.fr
Received: (qmail 29653 invoked from network); 8 Mar 2006 12:01:14 -0000
Received: from smtp6-g19.free.fr (212.27.42.36)
  by mrelay5-1.free.fr with SMTP; 8 Mar 2006 12:01:14 -0000
Received: from [127.0.0.1] (mtl93-4-82-226-131-24.fbx.proxad.net [82.226.131.24])
	by smtp6-g19.free.fr (Postfix) with ESMTP id A94FE206C6
	for <olivier.vit@free.fr>; Wed,  8 Mar 2006 13:01:14 +0100 (CET)
Message-ID: <440EC82F.10308@free.fr>
Date: Wed, 08 Mar 2006 13:03:59 +0100
From: Olivier Vit <olivier.vit@free.fr>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060307 SeaMonkey/1.5a
MIME-Version: 1.0
To: undisclosed-recipients:;
Subject: test 3
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta>
<meta name="ProgId" content="Excel.Sheet">
<meta name="Generator" content="Microsoft Excel 9">
aa aa aa aa 123 123 123 123
<link id="Main-File" rel="Main-File"
 href="file:///C:/temp/msoclip1/01/clip.htm">
<link rel="Edit-Time-Data"
 href="file:///C:/temp/msoclip1/01/clip_editdata.mso">
<link rel="OLE-Object-Data"
 href="file:///C:/temp/msoclip1/01/clip_oledata.mso">

<style>
<!--table
	{mso-displayed-decimal-separator:"\,";
	mso-displayed-thousand-separator:" ";}
@page
	{margin:.98in .79in .98in .79in;
	mso-header-margin:.49in;
	mso-footer-margin:.49in;}
tr
	{mso-height-source:auto;}
col
	{mso-width-source:auto;}
br
	{mso-data-placement:same-cell;}
td
	{padding-top:1px;
	padding-right:1px;
	padding-left:1px;
	mso-ignore:padding;
	color:windowtext;
	font-size:10.0pt;
	font-weight:400;
	font-style:normal;
	text-decoration:none;
	font-family:Arial;
	mso-generic-font-family:auto;
	mso-font-charset:0;
	mso-number-format:General;
	text-align:general;
	vertical-align:bottom;
	border:none;
	mso-background-source:auto;
	mso-pattern:auto;
	mso-protection:locked visible;
	white-space:nowrap;
	mso-rotate:0;}
.xl24
	{font-weight:700;
	font-family:Arial, sans-serif;
	mso-font-charset:0;}
-->
</style>
<table x:str="" style="border-collapse: collapse; width: 240pt;"
 border="0" cellpadding="0" cellspacing="0" width="320">
</table>
</body>
</html>




In case Blake can see a relationship with his work on bug 228920
Flags: blocking-seamonkey1.0.1?
SeaMonkey 1.0.1 should receive security and major stability fixes only.
Flags: blocking-seamonkey1.0.1? → blocking-seamonkey1.0.1-
duplicate of 228920 ?

Comment 10

13 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

13 years ago
(In reply to comment #9 [Olivier Vit])
> duplicate of 228920 ?

I don't know -- but that bug was fixed a week ago, altho the patch is only on the trunk.  Can you reproduce this bug's symptoms with a current trunk build?

I no longer see the symptom I describe in comment 4, using TB 3a1-0412, Win2K.
Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060913 SeaMonkey/1.5a
and Excel 2000

Pasting a table with rich text in cells (bold, italic) and borders on cells, results in a table with the cells values, but without any of the rich text properties.
Cell sizes are set in "pt" 

Saving as draft before sending  doesn't change anything

Comment 13

12 years ago
(In reply to comment #12)
>...
> Pasting a table with rich text in cells (bold, italic) and borders on cells,
> results in a table with the cells values, but without any of the rich text
> properties.
> Cell sizes are set in "pt" 

then this might be a dup of bug 195012 (which is a pretty old bug, which hasn't gotten any attention)

Comment 14

12 years ago
(In reply to comment #13)
> then this might be a dup of bug 195012

Maybe, but I don't think the symptom from comment 12 is the same as this original bug.  Oliver never responded to comment 11, but if he's seeing unformatted cells as the result of pasting, as opposed to no visible pasted results at all, I'd say this bug has been fixed, due the patch from 228920.


*** This bug has been marked as a duplicate of 228920 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 15

12 years ago
Confirming the fix: I can copy a block of cells from Excel 2003 into SeaMonkey 1.0.5 on German Windows XP SP2 Professional, and they become an HTML table.
You need to log in before you can comment on or make changes to this bug.