Last Comment Bug 308899 - AIX build break in xpconnect (xpcwrappednativeinfo.cpp)
: AIX build break in xpconnect (xpcwrappednativeinfo.cpp)
Status: VERIFIED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: Other AIX
: P1 major (vote)
: mozilla1.8beta5
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
: Phil Schwartau
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 20:05 PDT by Philip K. Warren
Modified: 2005-09-19 12:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch I just checked in; let's hope that fixes it. (926 bytes, patch)
2005-09-16 21:21 PDT, Boris Zbarsky [:bz] (still a bit busy)
dbradley: review+
brendan: superreview+
brendan: approval1.8b5+
Details | Diff | Splinter Review

Description Philip K. Warren 2005-09-16 20:05:54 PDT
I was able to successfully build Mozilla earlier this morning on AIX, but a
later checkin appears to have caused the following build break:

"/home/tbox/sb/tinderbox/AIX_5.1_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp",
line 695.19: 1540-0201 (S) The "delete" operator is not allowed for type
"AutoMarkingNativeInterfacePtrArrayPtr".
gmake[4]: *** [xpcwrappednativeinfo.o] Error 1
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2005-09-16 21:21:14 PDT
Created attachment 196390 [details] [diff] [review]
Patch I just checked in; let's hope that fixes it.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2005-09-16 22:19:01 PDT
So it looks like the AIX tinderbox is not really happy... pkw, does that patch
fix things for you?  If so, we should get it in on branch.
Comment 3 Philip K. Warren 2005-09-17 08:36:42 PDT
(In reply to comment #2)
> So it looks like the AIX tinderbox is not really happy... pkw, does that patch
> fix things for you?  If so, we should get it in on branch.

Sorry I had stopped the tinderbox until I got a chance to look at this further.
I am restarting it now.
Comment 4 Philip K. Warren 2005-09-17 12:54:43 PDT
Boris - thanks for the quick fix! The AIX tinderbox is now up and running again.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2005-09-18 07:53:27 PDT
Taking bug...
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2005-09-18 07:55:01 PDT
Comment on attachment 196390 [details] [diff] [review]
Patch I just checked in; let's hope that fixes it.

We need post-facto reviews for this bustage fix, I think, and we should get it
in on the branch...
Comment 7 Brendan Eich [:brendan] 2005-09-18 23:49:02 PDT
Comment on attachment 196390 [details] [diff] [review]
Patch I just checked in; let's hope that fixes it.

Someone remind me what the C++ ISO spec says, if it does prescribe
unambiguously and completely?

/be
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2005-09-19 10:32:23 PDT
Fixed on branch
Comment 9 David Bradley 2005-09-19 12:19:50 PDT
Comment on attachment 196390 [details] [diff] [review]
Patch I just checked in; let's hope that fixes it.

r=dbradley

Well even if AIX isn't quite correct, is it really going to matter?

Note You need to log in before you can comment on or make changes to this bug.