URL drag&drop regression from FF1.0 --> FF 1.06

RESOLVED DUPLICATE of bug 289513

Status

()

--
major
RESOLVED DUPLICATE of bug 289513
13 years ago
13 years ago

People

(Reporter: primorec, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

It is not possible anymore to drag&drop URL from the WEB page which is NOT
hyperlinked ( aka it is not clickable). I am talking here about  URL address on
the WEB page which is just pure ASCII string (typically black) and it does not
have hyperlink associated to it (aka blue clickable text).

This document describes a lot better the feature, which disappeared in the
latest incarnations of the Firefox ( an very likely mozilla as well)
http://downloads.mozdev.org/mozmanual/en/mozmanual.pdf

On the page 5 you can read the following text:
Drag and drop a link to an  open  space on the Tab Bar to open a link in a new
tab (Note: This even works for Internet locations shown as text, even if they
are not displayed as links!).

Reproducible: Always

Steps to Reproduce:
1.close ALL FIREFOX browsers
2.start FIREFOX 1.0
3.create TAB bar by pressing CTRL+T
4.type into address bar www.google.com
5.type into GOOGLE search window www.cnn.com and press ENTER
6.you will get on the screen the following text
Google can show you the following information for this URL:

    * Show Google's cache of www.cnn.com
    * Find web pages that are similar to www.cnn.com
    * Find web pages that link to www.cnn.com
    * Find web pages from the site www.cnn.com
    * Find web pages that contain the term "www.cnn.com"

NOTE: strings on the right end of the text are NOT clickable

7. highlight the NON clickable URL (press left mouse button, highlight the text,
release left mouse bitton)

8. click on the highlighted URL with the left mouse button (and do not release
the the button), drag the text to the open space on the TAB bar and release the
left mouse button.

9. FIREFOX 1.0 will accept the dropped URL, create new TAB and display the page
on the background. So, everything is fine.

NOW repeate the above procedure from 1. to 8. with FIREFOX 1.06. Of course,
FIRST CLOSE FIREFOX 1.0. This is very important.


Actual Results:  
With FIREFOX 1.06 drag&drop of the NON hyperlinked URL does NOT work.

Expected Results:  
FIREFOX 1.06 should create new TAB on the TAB bar and open the draged URL in the
backgraund.

You can drag&drop highlighted ASCII text from the browser to, for example, XTERM 
following the above procedure...  but you can NOT drop it to the TAB bar and
automagically create another TAB.

On top of that, you can NOT drag&drop the highlighed pure ASCII string to the
address bar of the browswer. It worked in FF1.0 and it does NOT work on FF1.06
anymore.

But, you CAN paste the the text to the address bar from anywhere using standard
X11 cut&paste sequrnce ( highlight the text with left button and drop it with a
middle button)
(Reporter)

Comment 1

13 years ago
I do not know if this feature works in 1.5 branch
Version: unspecified → 1.0 Branch
See also bug 306623, the only remaining issue.

*** This bug has been marked as a duplicate of 289513 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: 1.0 Branch → unspecified
(Reporter)

Comment 3

13 years ago
Where I can download Firefox 1.0? with this bux fixed ( according to bug report
289513 ) ?
Version: unspecified → 1.0 Branch
You can download the Firefox 1.5 Beta 1 at
http://www.mozilla.org/projects/firefox/ . Note that it is a beta, not a stable
release.
You need to log in before you can comment on or make changes to this bug.