Last Comment Bug 309075 - Right-clicking a partially off-screen link shouldn't scroll the page
: Right-clicking a partially off-screen link shouldn't scroll the page
Status: RESOLVED FIXED
: fixed1.8.1, testcase, verified1.8.0.1
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: x86 Windows XP
: P1 normal (vote)
: mozilla1.8.1
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
: Hixie (not reading bugmail)
Mentors:
https://bugzilla.mozilla.org/attachme...
: 322755 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 13:48 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2006-05-04 02:24 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch rv1.0 (3.14 KB, patch)
2005-11-07 12:40 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
roc: review+
roc: superreview+
Details | Diff | Splinter Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2005-09-18 13:48:28 PDT
Bug 105894 is fixed, but that bug is still happening when right-clicking a link.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2005-11-07 12:40:46 PST
Created attachment 202138 [details] [diff] [review]
Patch rv1.0
Comment 2 Boris Zbarsky [:bz] 2005-11-07 12:58:26 PST
That patch doesn't affect behavior when tabbing to the link?  That is, in that case we scroll?
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) 2005-11-07 13:58:21 PST
Yes, this affects only when the context menu is opened on the link by mouse.
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-11-11 19:34:06 PST
Comment on attachment 202138 [details] [diff] [review]
Patch rv1.0

looks good!
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) 2005-11-11 22:34:32 PST
checked-in.
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) 2005-11-11 22:34:54 PST
Sorry for the spam.

-> FIXED
Comment 7 Ria Klaassen (not reading all bugmail) 2006-01-08 09:47:12 PST
*** Bug 322755 has been marked as a duplicate of this bug. ***
Comment 8 Jay Patel [:jay] 2006-01-11 16:57:30 PST
v.fixed on 1.8.0.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1, no scroll when right-clicking partially off-screen link.

Note You need to log in before you can comment on or make changes to this bug.