Last Comment Bug 309099 - Entire screen is repainted each time focus moves
: Entire screen is repainted each time focus moves
Status: RESOLVED FIXED
: access, fixed1.8, perf
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 307545
  Show dependency treegraph
 
Reported: 2005-09-18 19:49 PDT by Aaron Leventhal
Modified: 2005-10-05 06:34 PDT (History)
5 users (show)
mtschrep: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple testcase (16.90 KB, text/html)
2005-09-18 19:50 PDT, Aaron Leventhal
no flags Details
Simple OSM torture testcase (17.01 KB, text/html)
2005-09-23 12:30 PDT, Aaron Leventhal
no flags Details
fix (3.75 KB, patch)
2005-09-26 20:49 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
aaronlev: review+
neil: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description Aaron Leventhal 2005-09-18 19:49:11 PDT
Each time I press tab, all lines of text on the screen are repainted.

This is one of the core causes of bug 307545.
Comment 1 Aaron Leventhal 2005-09-18 19:50:24 PDT
Created attachment 196611 [details]
Simple testcase
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-09-19 03:15:59 PDT
I guess this happens because of the fix for bug 151375.
Since that bug got fixed, the appearance of a focus outline cause an incremental
reflow. 
Comment 3 Aaron Leventhal 2005-09-19 06:37:06 PDT
Shouldn't we be able to do an incremental reflow and not repaint items that
haven't changed?
Comment 4 Steve England [:stevee] 2005-09-23 08:43:42 PDT
testcase wfm
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050923
Firefox/1.4 ID:2005092307
Comment 5 Aaron Leventhal 2005-09-23 08:54:26 PDT
(In reply to comment #4)
> testcase wfm
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050923
> Firefox/1.4 ID:2005092307

What did you test? You need to put in debugging statements to see how many lines
are repainted with each focus move.

It's not a readily apparent bug otherwise, unless you're running a screen reader
or possibly on a lower-end machine.
Comment 6 Aaron Leventhal 2005-09-23 12:30:26 PDT
Created attachment 197200 [details]
Simple OSM torture testcase
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2005-09-26 20:49:34 PDT
Created attachment 197507 [details] [diff] [review]
fix

Try this. It seems to help a lot for me.

On every focus change the ESM tells docshell the canvas no longer has focus.
The docshell then invalidates the entire window. Instead we should only
invalidate the window if the canvas previously had focus.
Comment 8 Steve England [:stevee] 2005-09-27 03:52:50 PDT
Re Comment 5
Apologies, I was looking for flickering whilst tabbing through the links on the
testcase.
Comment 9 Aaron Leventhal 2005-09-27 06:15:52 PDT
Comment on attachment 197507 [details] [diff] [review]
fix

This fixes most of the problem, which is good enough for Firefox 1.5. It's a
simple fix.

The only time it doesn't fix the problem is when tab is moving to or from the
canvas frame, but that can get fixed in Firefox 2.0 with the ExtTextOut work.
Comment 10 Asa Dotzler [:asa] 2005-09-30 16:49:48 PDT
Aaron, is there any way for our QA to easily verify this?
Comment 11 Aaron Leventhal 2005-09-30 17:54:53 PDT
(In reply to comment #10)
> Aaron, is there any way for our QA to easily verify this?

Not an easy way without downloading a screen reader. I already verified it. Just
have QA make sure it didn't break anything on trunk. However, I think we'll see
that nothing has regressed in the next day or two.
Comment 12 Aaron Leventhal 2005-09-30 18:02:29 PDT
The bug this really fixed is bug 307545.

Although I have already verified that this fixes that, I can have IBM QA double
verify this bug via bug 307545, since they already have Window-Eyes installed
and are accustomed to screen reader testing.
Comment 13 José Jeria 2005-10-05 06:34:38 PDT
Did this cause 311152?

Note You need to log in before you can comment on or make changes to this bug.